Melde dich an, um diesem Inhalt zu folgen  
arturo33

Was tun bei Performanceproblemen?

Recommended Posts

Quote

ShadowPlay or PlaystV

  • It seems ShadowPlay has been causing huge FPS drops for SOME people(reducing frames by like 50) for whatever reason. Make sure you have it disabled until Nvidia releases a driver update. I haven't seen many problems from AMD users but this might also apply to Raptr/PlaysTV, so disable these. To see how to disable ShadowPlay see this video:

    Drivers - Latest: AMD [16.10.2] 20th October, nVidia [375.57] 21st October

  • Even if you have the latest drivers, I recommend re-installing them using the method below. The auto-update or manual update of drivers (even if you uninstall the old ones first) can be problematic due to old remnants being left in your system somewhere.

  • Fully re-install your Nvidia/AMD drivers using DDU tool found here: http://www.guru3d.com/files-details/display-driver-uninstaller-download.html Run the program, it will reboot into safe mode and fully remove any trace of the old driver, then download the latest drivers from Nvidia or AMD.

  • !!!!! Always use DDU when updating or changing drivers !!!!!

  • Alternatively you could try some older drivers out, remove your current drivers (as above) then grab older drivers from these links:  Nvidia http://www.guru3d.com/files-categories/videocards-nvidia-geforce-vista-|-7.html or AMD http://www.guru3d.com/files-categories/videocards-ati-catalyst-vista-win-7.html

High/100% CPU usage - FIX 1 (EA are aware of this and will patch in due course)

Make a file name 'user.cfg' and place it in your Battlefield 1 folder, add the following lines:

gametime.maxvariablefps 60
RenderDevice.RenderAheadLimit 1

  • We're using 60 to limit the FPS, ideally you want this to match your refresh rate. If you're using a higher frequency display (i.e. 144hz) see if you get stable results at 60, then increase it gradually.

  • The RenderDevice.RenderAheadLimit is actually 0 by default, experiment with values 1,2 and 3.

  • You can also also change these values in nVidia/AMD control panel if you prefer, there's a discussion on this here: https://forums.battlefield.com/en-us/discussion/42847/high-cpu-usage-low-fps-potential-fix/p1

    High/100% CPU usage - FIX 2

  • Only one or two verified cases of this working but... try increasing your memory frequency within your BIOS, the XMP profiles should make this easy. Google search for specific instructions for your motherboard.

  • Overclocking CPUs (especially voltages) has been causing the game to crash. Try downclocking/volting.

  • Graphical Glitches on Aimens (AMD Specific)

  • If you're experiencing large 'sun' like light on your screen, or your screen going blue, black or red - try putting your lighting settings on Ultra. You can leave the other settings as they are, it fixed it for me and others but isn't definitive. This won't work if you apply mid game, you'll need to restart first. nmEF0Bf.jpg

    Other Tips

  • Try running the game in Borderless or Windowed Mode, this has improved FPS for some.
  • Make sure there is no memory limits in your BF1 advanced settings, either match it to your VRAM or set it to unrestricted.

  • Toggle DX12 on or off (Windows 10 only), you might see huge gains either way depending on drivers and hardware.

  • In Windows 10, make sure Xbox GameDVR is disabled. https://support.steampowered.com/kb_article.php?ref=6239-DZCB-8600#xboxapp

  •  

  • Unpark your cores (Windows 7 and 10) install ParkControl https://bitsum.com/parkcontrol/
  • Make sure parking is disabled MfrLUrt.png and hit 'Apply', you may also want to adjust Frequency Scaling so it's always giving 100%, change this BT0TXfP.png and hit 'Apply'. Bear in mind this will use more power as your CPU won't dynamically alter clock speed.
  • Please note to force constant max CPU performance (either by setting the Frequency Scaling to 100% in ParkControl, or by setting the 'Minimum CPU' state to 100% in your power settings: cefxdV4.png you MUST have C1E DISABLED and EIST ENABLED within your BIOS, you should be looking for something like this: QLHv2pf.jpg(please check the edits at the bottom for more info on power states)
  • If you have an i7 CPU, make sure Hyperthreading is enabled in your BIOS.
  • Unplug or disable your second/third monitor. People have reported a 20+ FPS drop just from having a second monitor plugged in. It's also worth adding that if you mirror the game on two screens with different frequencies you'll always have stutter.

    Other (unverified) solutions

  • Disable Superfetch in Windows http://www.technipages.com/windows-enable-disable-superfetch Do this last, re-enable it if it has no effect.

  • Windows Audio Device Graph Isolation has caused stutter in Battlefield 4 and other games, you could try turning it off: http://www.howtogeek.com/273764/what-is-windows-audio-device-graph-isolation-and-why-is-it-running-on-my-pc/

  • If you're using an older overclocked i5/i7 chip (2600k era etc.), you may see some benefits in disabling C3 and C6 power states in your BIOS.

Quelle: https://m.reddit.com/r/Battlefield/comments/57nh6y/bf1_performance_tips_for_pc_potentially_huge_fps/?utm_source=mweb_redirect&compact=true

Werde das bei Gelegenheit mal übersetzen. :)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Core unparking ist Quatsch. Das war früher mal ein Problem bei AMD FX Bulldozer CPUs und Windows 7.

Reddit geilt sich halt daran irgendwie immernoch auf.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Diverse PC-Konfiguarationen haben Probleme mit einbrechenden Framerates. Vom AMD 8350 bis zu aktuellen i5/i7 Prozessoren, selbst die Grafikkarten der aktuellen und letzten Generation haben Probleme mit den Frametimes und FPS Drops. https://forums.battlefield.com/en-us/discussion/41430/battlefield-1-fps-drops

Das kann ja nur besser werden. Mal abwarten was DICE da noch liefert.

Auf dauer ist Overlay deaktivieren und user.cfg erstellen auch nervig. :P

bearbeitet von arturo33

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kann es sein das der RenderAheadLimit-Wert zu input Lags führt?

Zumindest kann ich sagen das prerendered frames was bringen bei Performance Einbrüchen :)@Recki @Turnbeutel

bearbeitet von arturo33

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Problem:

Auf diversen Maps hatte ich am Start ein super flüssiges Spielerlebnis, aber irgendwann nach Mapchange ging das Gestottere los, Phänomen "rubberbanding"

Mainboard: Gigabyte z170x Gaming 
CPU: i5 6600k
Ram: 16 GB Corsair Vengeance DDR4
GPU: GTX 980Ti
SSD: Samsung 750 EVO
Monitor: ASUS ROG 2560x1440 @144hz

Texturqualität Ultra
Texturfilter Hoch 
Mesh Ultra 
Gelände Hoch
Der Rest ist entweder auf low, oder aus. 
Die Grafikeinstellungen sind aber nebensächlich, da selbiger Effekt auch bei low/high auftrat.

 

Lösung:

Folgende Variablen als .config im BF1 Ordner hinzugefügt:

gametime.maxvariablefps 60
RenderDevice.RenderAheadLimit 1

- lief scheinbar besser, aber so wirklich rund noch nicht.

Habe dann heute im englischen Forum folgenden Hinweis gesehen, der es für mich zu lösen scheint, rennt, zumindest im Moment, einwandfrei flüssig:

 

 


Viel Glück!

bearbeitet von Pe$tilence

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Bei mir hats was gebracht meinen Hitzestau im Gehäuse zu beheben indem ich es geöffnet habe. 10 Grad weniger auf der CPU scheinen was zu bringen.

@Turnbeutel hat es bei seinem AMD Prozessor ähnlich gelöst.

bearbeitet von arturo33

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
arturo33, vor 36 Minuten:

Bei mir hats was gebracht meinen Hitzestau im Gehäuse zu beheben indem ich es geöffnet habe. 10 Grad weniger auf der CPU scheinen was zu bringen.

@Turnbeutel hat es bei seinem AMD Prozessor ähnlich gelöst.

baut doch demnächst euern Rechner so auf ;)

83-14019.jpg

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Das ist bei mir halt das Leid des übertaktens. :ugly: Außerdem ist mir jetzt klar warum ich so derbe Performanceeinbrüche hatte:  Maximum operating temperature 72.6°C :ugly: Und ich hab mir so gedacht 70 Grad kann die Hütte locker ab. <_<

bearbeitet von arturo33

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich hab auch starke Performance Einbrüche. Sobald es richtig rund geht und es mal hektisch im Gefecht wird (zB. viele Explosionen, viele Gegner auf einem Haufen, im Flieger als Heckschütze), hab ich sehr starke Ruckler und das Zielen und treffen wird zum Lotto.

Hab auch schon einiges im Hintergrund ausgeschaltet, die Graka etwas übertaktet, die CPU ist minimal hoch getaktet. Den BF1 Dienst auf hoch gestuft. Die Grafik auf Mittel stehen, Post anti aliasing aus, Effekte auf niedrig. HBO auf niedrigste Einstellung. 

Irgendwie is es trotzdem unbefriedigend.

 

System:

Windows 10 64bit

AMD FX8350 @ 4.0 GHz

8 GB RAM

GeForce GTX 1070 8GB

 

Sollte doch zumindest auf Mittel sehr flüssig laufen, oder nicht?

:kritisch:

 

bearbeitet von DaWallace

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe einen i5-2500k, eine GTX760, und 16Gb RAM, und ich spiels auf "hoch".  *lol*

Allerdings bei 1680 x 1050 Pixeln Auflösung. Das sind etwa 15% weniger Pixel als Full HD.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Joa....schön. Das löst nur nicht das Problem was scheinbar mein System hat. Irgendwas muss da ja extrem stören.

Hab Gestern Nacht noch bei der XBOX App  den DVR Record abgeschaltet und bei den NVIDIA Settings die Pre-Rendered Frames mal auf 1 gesetzt. Aber noch nicht getestet. Werd ich heute mal testen ob das was gebracht hat.

 

Im Gegenzug läuft Squad jetzt flüssig ohne Probleme, seit ich die GTX 1070 drin habe. :kritisch:

bearbeitet von DaWallace

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Optimierung auf AMD Prozessoren is nach wie vor immer noch recht mies, ich schau heute Abend mal ob ich nen Lösungsansatz finde. Ansonsten könnte @Turnbeutel mal seine Erfahrungen posten, er hat auch nen AMD Prozessor. :)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
DaWallace, On 26.11.2016 at 15:10:

Joa....schön. Das löst nur nicht das Problem was scheinbar mein System hat. Irgendwas muss da ja extrem stören.

Hab Gestern Nacht noch bei der XBOX App  den DVR Record abgeschaltet und bei den NVIDIA Settings die Pre-Rendered Frames mal auf 1 gesetzt. Aber noch nicht getestet. Werd ich heute mal testen ob das was gebracht hat.

 

Im Gegenzug läuft Squad jetzt flüssig ohne Probleme, seit ich die GTX 1070 drin habe. :kritisch:

Ich habe einen leicht stärkeren AMD Prozessor, ansonsten ein fast identisches System und spiele auf Ultra. Gelegentlich droppen die Frames mal auf Anfang bis Mitte 50. Etwas Linderung hat es gebracht Nvidia Experience zu beenden, aber das liegt definitiv and der CPU. Witziger Weise läuft das Spiel besser je höher ich die Grafik schraube.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Geht einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

Melde dich an, um diesem Inhalt zu folgen  

  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.