Jump to content

Archived

This topic is now archived and is closed to further replies.

Lotte

BF1942 Linux Gameserver auf Dualcore Systemen

Recommended Posts

Ja, Taskset ist längst ausprobiert, wirkt auch nicht :(

Ein altes 32 bit Linux wär doch beispielsweise Suse 10.2-32 bit.

Auch damit haben wir den Matrix-Effekt.

Was auffällig ist, ist dass trotz weniger Bots (gestern waren von 24 Slots 18 Spieler also nur 6 Bots), der Util%-Wert auf 120% hochgeht !

Komischerweise nur auf dem Linux Root.

Habe dieselbe Map anschließend zuhause auf einem AMD 3200 laufen lassen und dort ging es mit 64 Bots (!!!!!!!!!!!!!) nicht über 30% und lief perfekt.

Liegt's also doch am Dualcore ???

Share this post


Link to post
Share on other sites

ich werde das hier auf meinem dualcore auhc noch mal ausprobieren. das ist ein AMD X2 4600 mit 2 GB RaM.

mal schauen ob das klappt, wenn es klappt und stabil läuft, liegts evtl an der Hardware eures root ?

Share this post


Link to post
Share on other sites
Liegt's also doch am Dualcore ???

Ich würde mal ganz stark drauf tippen, so, wie sich das Problem darstellt. Sag mal, ohne Bots ging es gestern aber dann ohne größere Probleme, oder hat der Server sich dann auch wieder abgeschossen?

Share this post


Link to post
Share on other sites

Meiner läuft nur im Conq Modus.

Inerresant ist aber, das die Probleme ab ca 10 Spielern anfangen. So habe ich das zumindest mitbekommen.

Andere Server mit mehr Spielern haben aber keine Probleme. Leitung ist es also nicht.

Share this post


Link to post
Share on other sites

Ich weiss ja nicht ob es was bringt aber könnt ihr den AMD Dual Core Optimizer auch auf die Server installieren ?? BF 42(eigentlich alle BFs aber BF42 und Vietnam extrem) und Zweikern CPUs scheinen sich nicht zu mögen und verursachen da eine Menge seltsamer Fehler.

Share this post


Link to post
Share on other sites

ich denke das würde nichts bringen, wenn man den emulieren würde.

aber komissch ist das schon, das obwohl dem nur ein kern zugewiesen ist, der die macken hat.

Kannst du noch mal posten, was da alles drauf läuft und was der für eine Hardware hat ?

Ich habe gerade im ASE gesehen , das der "nur" mit 1000Mhz läuft. Das ist ja bei dem powersave ganz normal, aber ich hatte das auch schon mal auf einem anderen server, das dort was mit dem powsersaved-daemon nicht richtig lief und ich den manuell noch mal instruktionen geben mußte, evtl hat der bei dir/euch uch einen macken und haut euch deswegen die Fehler rein.

die 1Ghz sind ja sozusagen das Grundrauschen, euer sollte ja bis 2,6 oder mehr problemlos laufen und wenn da noch einige andere server laufen ist das etwas komisch, das der nur so wenig verbraucht.

Share this post


Link to post
Share on other sites

Ich gehe von aus, das du die Stromsparfunktion meinst, oder was hast du wo angepasst?

Aso, ich benutze den Kernel:

Linux Debian-40-etch-64-minimal 2.6.18-5-amd64 #1 SMP Sat Dec 22 20:43:59 UTC 2007 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

genau die meine ich. ich mußte hier einmal "powersave -A" eingeben, damit er überhaupt hochskaliert mit seiner Leistung.

vorher war der auch imemr nur bei 1000 Mhz. danach klappte das hervorragend.

aber evtl mal die anderen parameter durchgehen. der eine war glaubei ch ja für den "performance mode" als das der immer mit volldampf läuft.

Zur not den mal testen.

Share this post


Link to post
Share on other sites

Simpson hervorragende Arbeit.

Heute Abend lief der Server erste Sahne, nicht ein Lag.

powersave einstellen und nice-Wert herabsetzen hat geholfen.

Aber am besten Simpson erklärt mal was und wie er es genau gemacht hat.

Hoffentlich hält es jetzt dauerhaft :)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.