Jump to content

Archived

This topic is now archived and is closed to further replies.

Narchen

Setting up Gamespy and ASE for Internet Game

Recommended Posts

Hallo,

habe auf meinem gemieteten Rootserver BF1942 installiert.Ich habe alles nach Anleitung gemacht : http://wiki.bf-games.net/index.php/BF1942_Gameserver_unter_Linux#Allgemeines

Ports etc. sind richtig freigegeben.

Nun zu meinem Problem: Der Server startet, aber ich bekomme immer die Meldung :Setting up GameSpy and ASE for internet game. The GameSpy QR SDK failed to initialize.

Habe in der serversettings.con game.serverInternet 1 game.gameSpyPort 1 game.ASEPort 1 eingestellt.

Achso noch was zum BS ist ein OPenSuse 11.3 Root Server

Share this post


Link to post
Share on other sites

Joar, da haste dir die Frage doch schon selbst beantwortet, oder? Du hast GameSpy- und ASE-Port beide auf eine 1 gesetzt. Dort ist kein Boolean (0 oder 1), sondern wirklich die Portnummer (normal 23000 bzw. 14690) zu setzen.

Share this post


Link to post
Share on other sites

Ah ok,stand aber so in ner anleitung die ich im netzt gefunden habe,werde es testen und mich dann nochmal melden.

Habs gemacht,die Ports eingetragen.Kommt aber immer noch die selbe meldung.Setting up GameSpy and ASE for internet game

Share this post


Link to post
Share on other sites

Hi,

ich habe das selbe Problem! Wenn der Server läuft steht immer folgendes da:

Setting up GameSpy and ASE for internet game

wenn ich im Spiel direkt über 192.168.2.102:14567 connecte komme ich auf den Server.

hier mal meine seversettings.con

game.serverName "BfServer"

game.serverDedicated 1

game.serverGameTime 0

game.serverMaxPlayers 32

game.serverScoreLimit 0

game.serverInternet 1

game.serverNumberOfRounds 3

game.serverSpawnTime 20

game.serverSpawnDelay 3

game.serverGameStartDelay 20

game.serverGameRoundStartDelay 10

game.serverSoldierFriendlyFire 100

game.serverVehicleFriendlyFire 100

game.serverTicketRatio 100

game.serverAlliedTeamRatio 1

game.serverAxisTeamRatio 1

game.serverCoopAiSkill 75

game.serverCoopCpu 20

game.serverPassword ""

game.serverReservedPassword ""

game.serverNumReservedSlots 0

game.setServerWelcomeMessage 0 ""

game.serverBandwidthChokeLimit 0

game.serverMaxAllowedConnectionType CTLanT1

game.serverAllowNoseCam 1

game.serverFreeCamera 0

game.serverExternalViews 1

game.serverAutoBalanceTeams 0

game.serverNameTagDistance 50

game.serverNameTagDistanceScope 300

game.serverKickBack 0.000000

game.serverKickBackOnSplash 0.000000

game.serverSoldierFriendlyFireOnSplash 100

game.serverVehicleFriendlyFireOnSplash 100

game.serverIP 192.168.2.102

game.serverPort 14567

game.gameSpyLANPort 22000

game.gameSpyPort 23000

game.ASEPort 14690

game.serverHitIndication 1

game.serverTKPunishMode 1

game.serverCrossHairCenterPoint 1

game.serverDeathCameraType 1

game.serverContentCheck 1

game.serverEventLogging 0

game.serverEventLogCompression 0

game.objectiveAttackerTicketsMod 100

Der Server wird auch in HLSW über 192.168.2.102:14567:23000 gefunden.

Ports habe ich alle weitergeleitet so wie hier beschrieben!

Kann mir jemand dabei helfen den Server online zu stellen?

gruß

mrjingles

Share this post


Link to post
Share on other sites

Dein Server ist im Heimnetz, kann sich jemand mit der DSL-IP verbinden? Hast Du eine Dyndns, no-ip oder einen ähnlichen Service, damit der Server mit einer immer gleichen Adresse erreichbar ist?

Share this post


Link to post
Share on other sites
kann sich jemand mit der DSL-IP verbinden?

Hast Du eine Dyndns, no-ip oder einen ähnlichen Service, damit der Server mit einer immer gleichen Adresse erreichbar ist?

ich bin mir nich sicher was du mit DSL-IP meinst. Ich habe mal einem kolleg gesagt er soll versuchen über 192.168.2.1:14567 zu connecten aber das hat nicht geklappt. Fehlermeldung: "Verbindung zum Server fehlgeschlagen"

Ja ich benutzte den service von no-ip für meinen ts3 server.

gruß

mrjingles

Share this post


Link to post
Share on other sites
Ich habe mal einem kolleg gesagt er soll versuchen über 192.168.2.1:14567 zu connecten aber das hat nicht geklappt.
Na, solange er nicht bei Dir zu Hause im Netzt ist, wird das nicht klappen. Er muß sich dann mit der no-IP-Adresse verbinden, vorrausgesetzt die Portfreigaben sind im Router richtig eingegeben.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.