Jump to content

Archived

This topic is now archived and is closed to further replies.

illMoh

Spiel ruckelt nach ca. 10 Minuten

Recommended Posts

Deine Hardware reicht für BF42 und dessen Mods vollkommen aus. Lass Dir da keinen Quark erzählen!

Unter Win7 gibt es keine Einstellungen für die Hardwarebeschleunigung für den Sound. Das war bereits unter Vista bzw. seit DirectX 10 nicht mehr manuell zu ändern. Das macht der Soundtreiber nun automatisch, soweit ich weiß. Ich habe eine Audigy 2 Soundkarte und nicht einmal da kann ich die Hardwarebeschleunigung ändern. Unter XP bzw. DirectX 9 war das kein Problem.

Ich bin vor kurzem von XP auf Win 7 32bit umgestiegen und habe ein ähnlich "altes" System von den Hardware-Komponenten her.

Deine Frameraten-Einbrüche kenne ich zu gut. Hatte gestern bei einem Fun Match Einbrüche bis auf 10 FPS und es waren keine Gegner oder Explosionen in meiner Nähe.

Ich habe alle Treiber aktualisiert und auch in den NVIDIA-Einstellungen wirklich alles deaktiviert(kein Anti-Aliasing, Texturfilterung, Dreifach Puffer, Threaded-Optimierung...usw.).

Nach dem Starten von Bf42 in den Taskmanager wechseln und nur eine CPU auswählen und die Priorität der bf1942.exe höher stellen, brachte keinen Erfolg.

Habe sogar die bf1942.exe mit "CFF Explorer" so geändert, dass mehr als 2 Gb Arbeitsspeicher unterstützt werden.

Nichts hat geholfen.

Aber dann...

Normalerweise starte ich Battlefield über Xfire. Ich habe Xfire probehalber mal ausgeschaltet und BF über die bf1942.exe gestartet. Siehe da! Keine Frameraten-Einbrüche mehr! Wenn man Xfire aber laufen lässt und BF über die bf1942.exe startet, bekommt man wieder das gleiche Problem. Ich kann mir nicht erklären was Xfire damit zu tun haben soll, aber bisher ist das Problem nicht mehr aufgetreten. An meiner Internetleitung kann es nicht liegen, da ich DSL 16000 habe und das Problem bei Forgotten Hope 2 im Zusammenspiel mit Xfire z.B. nicht auftritt. Lief unter XP ja auch...

Wenn Du jetzt kein Xfire benutzt, dann müssen wir weiter suchen. Deaktiviere dann mal alles im Taskmanager und starte BF über die bf1942.exe .

Share this post


Link to post
Share on other sites

richtig, xfire ist schuld. habe ich schon vor einem jahr festgestellt.

unter xp keine problerme, nur wenn win7 und komp-modus und dann xfire an --> 100->10fps, erholend, dann wieder runter. bis zu nem freeze von einer sekunde.

edit: es reicht, dass xfire laeuft, man muss nicht einmal bf daruber starten.

Share this post


Link to post
Share on other sites

Dann stellt in den Xfire Optionen mal bei den Einstellungen für BF1942 die Ingame Option aus. Dann müsste Xfire auch nebenbei laufen können.

Aber seit wann habt ihr die Probleme mit Xfire? Ich hab hier auch Win7 64-bit und Xfire laufen und hatte nie Probleme mit BF1942. Oder gibts das erst seit kurzem?

Wobei, du schreibst da was von über einem Jahr. Und zu der Zeit hatte ich ziemlich sicher keine Probleme mit Frameeinbrüchen in Bezug auf BF1942 + Xfire.

Share this post


Link to post
Share on other sites
edit: es reicht, dass xfire laeuft, man muss nicht einmal bf daruber starten.

Na, sag ich doch. Steht doch schon oben, gonzo. ;)

Share this post


Link to post
Share on other sites

Freut mich, dass ich endlich nochn paar Leute finde die das Problem überhaupt haben bzw. hatten. Aber leider muss ich auch hier verneinen. Habe X-Fire garnicht installiert und auch seit bestimmt 5 Jahren nicht mehr genutzt. :/

Share this post


Link to post
Share on other sites

irgend ein anderes overlay-programm? oder etwas den sound auch noch betreffend? ich hatte mal ts im verdacht, war aber ts2 und das lief ja nun wirklich ewig lange ohne veraenderung. ich muss dazu sagen, mein xfire-prob gabs auch unter xp-64.

ich denke jedenfalls nicht dass es bei dir ein treiberproblem ist, wenn es denn schon einmal rund lief.

such weiter ;)

Share this post


Link to post
Share on other sites

bei einem clan mitglied lag es angeblich an teamspeak 3.

hast du denn mal alles andere im task manager geschlossen und dann bf gespielt?

Share this post


Link to post
Share on other sites

Halte meinen Rechner immer schon sauber, daher läuft im Hintergrund nich. Aber ich versuch morgen mal wirklich alles außer BF auszuschalten. Ob das dann was bringt sieht man ja dann. :( Kack Microsoft, dass die keine Hardwarebeschleunigung mehr eingebaut haben bzw. sie nicht zumindest simulieren...

Share this post


Link to post
Share on other sites

Vielleicht kann man darüber auch die Sound Hardwarebeschleunigung einstellen. Für die Grafikbeschleunigung soll es damit jedenfalls gehen. Ob Dir das bei Deinem Problem dann hilft, weiß ich natürlich nicht. Wie gesagt, ich kann in den BF42-Internen Optionen die Hardwarebeschleunigung auch nicht aktivieren, obwohl ich eine Soundkarte benutze.

DirectX Software Development Kit

Das DirectX Software Development Kit für Windows XP, Windows Vista, Windows Server 2003/2008 und Windows 7 (x86/x64) enthält Updates für Tools, Utilities, Samples, Dokumentation und Runtime-Debug-Dateien für 32-bit- und 64-bit-Plattformen von Windows.

Im SDK ist sämtliche DirectX-Software enthalten, die für das Erstellen von Anwendungen mit den Multimediaschnittstellen auf Windows benötigt wird. Das Tool ist insgesamt 572 MB groß.

http://www.wintotal.de/tipparchiv/?id=1804

Share this post


Link to post
Share on other sites

Was hast Du für eine Internetanbindung? Insbesondere der Upload ist wichtig. Es kann sein, daß da ab und zu Punkbuster alles zu macht oder wenn viele Fahrzeuge sich an einer Stelle befinden, daß der Upload nicht ausreicht.

Share this post


Link to post
Share on other sites

Wenn ich das richtig verstehe hast du mehrere Soundkarten gleichzeitig in Betrieb (aktiviert in Windows).

Wenn du jetzt "Systemsteuerung" -> "Sound" anwählst welche ist dort als Standardgerät eingetragen ?

Check mal ob die Karte die du in BF1942 verwendest auch den Haken als Standardgerät für die Ausgabe hat.

Das KÖNNTE (muss nicht) Konflikte verursachen, wenn du in BF1942 ne andere Karte wählst als dort als Standardausgabegerät eingetragen ist.

Edit:

Außerdem check mal, wenn du die Soundkarte (für BF1942) angewählt hast unter Eigenschaften -> Reiter "Erweitert" ob die zwei Haken gesetzt sind.

- bla "Alleinige Kontrolle" bla

- bla "exklusiven Modus" bla

Edit2:

In der Sound.con Datei könntest du mal rumspielen, wenn obiges nicht hilft.

Stell aber diesbezüglich bitte keine weitergehenden Fragen an mich, ich hab keinen Plan mehr "was da genau was war", da ich echt ewig kein BF1942 mehr gepimpt habe

1 = an

0 = aus (sollte eigentlich klar sein) ;)

Sound.setDopplerFactor 1/0 (Turns on/off 3D Audio effects)

Sound.setRolloffFactor 1/0 (As above)

Sound.setDistanceFactor 1/0 (As above)

Sound.setPitchChangeRate #

Sound.showSoundInfo 1/0 (Toggles information display about the sound performance)

Sound.drawSoundObjects 1/0 (As above)

Share this post


Link to post
Share on other sites

Also das mit dem Direct X Developper Kit is ne gute Idee, das werde ich mal ausprobieren.

Nein wie gesagt es hat nichts mit der Internetverbindung o.ä. zu tun.

Was die Soundkarte beim Battlefield angeht, so nutzt das Spiel ja immer das Standartaudiogerät welches ich vorher eingestellt habe. Alle anderen sind in der Zeit inaktiv. Was ich aber nicht verstehe ist, wie kann man denn IN BF1942 ne andere Soundkarte auswählen?

Die Haken sind gesetzt. Aber ich habe auch mal gelesen, dass man sie bei Problemen "nicht ankreuzen" sollte. Wie auch immer habe es schon mit und ohne probiert. :-/

Die BF Sound.con Datei wär noch ne Idee, aber auch da mach ich mir wenig Hoffnung, weil ich nämlich schon so schlau war und die Hardwarebeschleunigung mit der ASUS angeschaltet hab, dann das Spiel beendet und mit ner anderen neu gestartet hab. Dann komm ich allerdings nicht weiter als ins Menü. Dennoch werde ich das mal probieren, danke für den Tip. Ahja aber wenn ich showSoundInfo 1 mache, wo wird mir die Soundinfo dann angezeigt?

Danke schonmal an alle.

Share this post


Link to post
Share on other sites

Ups, mein Fehler bei BF1942 kann man die Soundkarte ja garnicht auswählen :puuuh:

Ich hatte das Problem in ner anderen Anwendung mit ner externen USB daher kam ich drauf.

Letzter Versuch meinerseits

...\EA GAMES\Battlefield 1942\Mods\bf1942\Settings\Profiles\Custom\sound.con

Öffnen mit "Wordpad"

unten müßtest du

game.setHardware 0

finden, dies müßte die Hardwarebeschleunigung gewesen sein...

ändere mal in

game.setHardware 1

Datei speichern und dann die Datei per Rechtsklick schreibschützen.

BF1942 starten und testen !

Share this post


Link to post
Share on other sites

Mhh nee funktioniert auch nicht, das is der gleiche Effekt wie wenn ichs mit der ASUS umstelle und dann mit ner anderen wieder reingehe. Spiel stürzt dann ab. :( Gibt wohl keine Lösung für das Problem was!?

Share this post


Link to post
Share on other sites
Guest -(HC83)-

wurde eigentlich mal ausprobiert alle Soundkarten zu deaktivieren und das Spiel dann mal laufen zu lassen? Also die Onboard Karte im Bios aus stellen und die andere am besten mal ausbauen!

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.