Archiviert

Dieses Theme ist nun archiviert und für weitere Antworten gesperrt.

Sven

Patchswitcher 1.2 <> 1.21

Recommended Posts

So, ich habe mich mal hingesetzt, und einen Patchswitcher für Vietnam zu bauen, ähnlich wie dem für BF 1942. Ich muß morgen noch zwei, drei Sachen ändern, dann werde ich den Hochladen. Diesmal sind es ein paar MB mehr, genauer gesagt ca 120 MB, die installiert werden, weil sich ein paar Dateien mehr, als bei BF1942 geändert haben. Ich habe gerade mal eine Runde auf einem 1.2-er Server gezockt und werde jetzt noch mal einen 1.21-er testen.

Zu finden ist das Projekt bei Sourceforge: https://sourceforge.net/projects/battlefieldviet/,

ich richte den ersten Download gleich ein, allerdings funktioniert im Moment nur das Umschalten zwischen den Versionen richtig. Den Rest muß ich am Wochenende testen und korrigieren. Das habe ich erst mal vom BF 1942-Projekt 1:1 übernommen und nur teilweise angepaßt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

So hast du aber 2 Installationen von BFV auf der Platte. Ist nicht gerade Ressourcen schonend ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Man braucht nicht zwei Installationen, sondern es werden nur die Dateien ausgetauscht, die bei den Versionen unterschiedlich sind, und das sind genau diese hier:

  • bfvietnam_w32ded.exe
  • BfVietnam.exe
  • init.con
  • LevelCheck.con
  • font.rfa
  • objects.rfa
  • standardMesh.rfa

Das sind in der Summe 260MB.

Mehr brauchen nicht ausgetauscht zu werden und es funktioniert, ich hatte gestern sowohl auf 1.2-er, als auch auf 1.21-er Server erfolgreich gespielt. Unter anderem die WWII-Mod im Coop auf einem 1.2-er Server. War zwar mit nem 100-er Ping etwas laggy, hat aber funktioniert.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

So, ich lade es gerade noch mal hoch, in der gleichen Version. Nun müßte es soweit auch funktionieren, daß man einen Server abfragen kann und die Variablen und auch die Spieler angezeigt werden. Und bei Start die entsprechende Version automatisch eingestellt wird.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin

Du warst das also bei uns auf dem server.

Na das ja mal super mit dem Patchswitcher habs 2 mal installiert bei mir is echt übel mit den ganzen mods.

Aber wer mal lust hat auf nem deutschen server zu daddeln mit gutem ping (ich habe nen 9er Ping) in 1.2 guckt mal nach den =[TF]= Servern is einer normal und einer mit PoE/EoD mod am laufen und bei lust und laune schnalltz mal bei uns in ts rein.

IP's findet ihr auch alle auf unserer HP.

mfg Team-Fantas

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Wieso bau ihr überhaupt einen Patch Switcher für BFV. 1.21 war doch ein Sicherheits Update :kritisch:

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Version 1.61 für BF1942 ist auch ein Sicherheitsupdate und trotzdem gibt es noch Server auf den 1.6 läuft und somit nicht mitspielen kann wenn man selber 1.61 drauf hat. So ist es auch bei BFV, da dort noch weniger Server und Spieler verfügbar sind ist der Patchswitcher noch ein bisschen wichtiger als bei BF1942. Sonst hat man da kaum auswahl.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Genau, es gibt jede Menge Server, die noch auf Version 1.2 laufen, eigentlich sogar mehr, als 1.21-er. Ich denke, das Sicherheitsupdate wird eher den Server betroffen haben.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.