Jump to content
MachtNüx

Problem mit -configdaemon

Recommended Posts

Moin moin.

Ich hab mal wieder nen BF2-server auf Linux (Suse 9.1) aufgesetzt., dazu den PoE2-Mod. Die Installation funktionierte auch so weit ganz gut. Ich bekomm den Server nach Änderungen in den Serversettings auch zum laufen. Connecten kann sich auch jeder und darauf zocken.

Nun mein Problem:

Eigentlich sollte man den Server über BF2CCD administrieren können. Dem geht aber bei mir nicht. Ich habe mono (1.1.9.2) installiert. BF2CCD ist in der Version 1.4.2439 auch installiert.

Wenn ich nun den Befehl <mono bf2ccd.exe -configdaemon> ausführe, bleibt das Programm nach Eingabe der Passwortbestätigung einfach hängen. Danach passiert nix mehr.

Ich hab echt keine Ahnung, was da schief läuft!?

Hilfe!

Link to comment
Share on other sites

Guest

Hi!

Wenn ich nun den Befehl <mono bf2ccd.exe -configdaemon> ausführe, bleibt das Programm nach Eingabe der Passwortbestätigung einfach hängen. Danach passiert nix mehr.

Passiert der Fehler bei den ersten Einstellungen die Du machen willst wo Du nach einem Adminpasswort gefragt wirst?

Wenn ja, dann lass das Passwort leer denn das musst Du bei der ersten Konfiguration nicht unbedingt eingeben. Danach kannste Dich mit diesem Account anmelden:

Username = admin

Passwort = admin

Link to comment
Share on other sites

Kann ich den Befehl ... -configdaemon auch jetzt noch ausführen, wenn der Server schon gelaufen ist!?

Wenn ja, dann muss ich mitteilen, dass das Config-Programm auch hängen bleibt, wenn ich kein passwort eingebe.

Wenn Nein, muss ich wohl den ganzen BF2-Server neu installieren!?

Link to comment
Share on other sites

Guest
Kann ich den Befehl ... -configdaemon auch jetzt noch ausführen, wenn der Server schon gelaufen ist!?

Mhhh, muss ich passen. Du kannst aber einfach mal den BF2CC beenden, danach die users.xml und config.xml aus dem Verzeichniss in dem der BF2CC liegt in nen anderen Ordner verschieben und dann nochmal mono bf2ccd.exe ausführen.

Wenn ja, dann muss ich mitteilen, dass das Config-Programm auch hängen bleibt, wenn ich kein passwort eingebe.

Dann Update mal auf Mono 1.1.12.1, hab gerad nen 1.4er BF2 Server mit der aktuellsten BF2CC Version aufgesetzt und da hat das ohne Probleme funktioniert. Nur läuft da 1.1.12.1...

Link to comment
Share on other sites

Hab nun auch Mono 1.1.12.1 installiert. Hab die beiden XML-Dateien gelöscht und per ...-configdaemon neu konfiguriert. Es bleibt dabei: wieder bleibt er stehen, sobald ich das Passwort eingebe. Egal ob ich´s frei lasse oder ein´s reinschreibe. Werd wohl den Server noch mal aufsetzen.....

schau ´mer ma...

*edit*

Ist zum verzweifeln. Nun hab ich den Server neu aufgesetzt, hab sogar erst einmal die Erweiterung PoE2 weggelassen und nur bf2ccd in den betreffenden Ordner kopert. Und er bleibt bei Befehl "mono bf2ccd.exe -configdaemon" immer noch nach dem Passwort hängen.....

Edited by MachtNüx
Link to comment
Share on other sites

sorry, aber wenn du "mono bf2ccd.exe -configdeamon +config /dein_pathbf2/mods/bf2/settings/serversettings.con +mapList /dein_pathbf2/mods/bf2/settings/maplist.con"

meinst, da passiert auch nix weiter. Meine Vermutung ist ja, dass Mono 1.1.12.1 nicht bei Suse 9.1 funktioniert.

Link to comment
Share on other sites

Guest

Haste das im Griff? Ansonsten häng ich Dir mal die Dateien hier an welche mit dem -configdaemon Parameter erstellt werden...

Link to comment
Share on other sites

Guest

Ok dann beende den BF2CCD (falls der noch läuft), kopiere die 4 Dateien im angehängten Archiv dahin wo die bf2ccd.exe liegt. Danach musst Du in der config.xml diese Werte anpassen:

<GameFolder>/pfad/zum/bf2ordner/</GameFolder>

<DaemonIP>0.0.0.0</DaemonIP>

<DaemonPort>6712</DaemonPort>

(sollten selbstklärend sein)

und danach kannst Du dann den bf2ccd starten. Jetzt noch mit:

Username: admin

Passwort: admin

einloggen und schon kannst Du den Server administrieren. Wichtig ist dann noch dass Du den Standard- Adminlogin umänderst...

bf2ccd.xml.zip

Link to comment
Share on other sites

Ich trau´s mich gar nicht zu sagen.... :rolleyes:

ich hab den Fehler gefunden. Der Port war schon belegt. Hab´s durch Zufall in der bf2_log gefunden. Da jetzt der Port 6711 eingestellt wurde, ging´s plötzlich.

Manchmal hat man doch ein Brett vor´m Kopf... ;)

Link to comment
Share on other sites

Guest

Mhhh, komisch das dann keine Fehlermeldung vom BF2CC kam. Aber egal, hauptsache es läuft jetzt... :D

Link to comment
Share on other sites

Hab ein kleines, aber komisches Problemchen.

Ich kann jetzt auf die Konsole connecten, er schreibt mir auch, dass RCon und Daemon ohne Probleme gestartet sind.

"===== DAEMON SETTINGS LOADED WITHOUT PROBLEMS =============="

Hab die Maps von PoE2 ausgesucht. (Egal welcher Modi, es kommt immer der gleiche Fehler)

Wenn ich nun den Server startet, kommt nach kurzer Zeit:

"BF2 process has stopped on Map: Unable to Query Map Name"

Hatte erst gedacht, liegt an den Karten; PoE2 läuft nicht. Wenn ich aber die Standartmaps von BF2 einstelle, passiert dasselbe.

Woran kann das nun liegen!?

Als Prozess läuft:

"/home/admin/bin/bf2/bin/ia-32/bf2 +config mods/bf2/settings/serversettings.con + ..."

Müsste dort nicht .../mods/poe2/... stehen? Aber wo stell ich das ein?

In der Log steht folgendes....

"[09/19/2006 21:10:20] SYSTEM Restarting process

[09/19/2006 21:10:21] SYSTEM BF2 process has stopped on Map: Unable to Query Map Name

[09/19/2006 21:10:21] SYSTEM Process terminated waiting for 10 seconds before restart.

[09/19/2006 21:10:31] SYSTEM Server Start Check: Checking RCON port: 6711

[09/19/2006 21:10:31] SYSTEM Check passed!

[09/19/2006 21:10:31] SYSTEM Server is starting in NON RANKED mode.

[09/19/2006 21:10:32] SYSTEM Starting in: /home/admin/bin/bf2/

[09/19/2006 21:10:32] SYSTEM Starting Mod: poe2

[09/19/2006 21:10:32] SYSTEM Started file: /bin/sh start.sh

[09/19/2006 21:10:32] SYSTEM BF2 process is starting

[09/19/2006 21:10:32] SYSTEM Restarting process

[09/19/2006 21:10:33] SYSTEM BF2 process has stopped on Map: Unable to Query Map Name

[09/19/2006 21:10:33] SYSTEM Process terminated waiting for 10 seconds before restart.

"

Edited by MachtNüx
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.