Jump to content
Sign in to follow this  
Dr. Dünnpfiff

Problem mit SuSe 10.0 & Windows XP

Recommended Posts

Hi,

ich hab gestern endlich wieder SuSe auf meinem Rechner installiert.

Ich meine auch, alles wie sonst auch gemacht zu haben, was die Einstellungen während dem Setup angeht.

Einziger Unterschied ist, dass SuSe jetzt eine eigene Festplatte hat. Vorher hatte ich nur eine, aber da jetzt Win XP schon meine SATA Platte belegt, hab ich für SuSe noch ne IDE-Platte reingehängt.

Linux läuft einwandfrei, das Problem ist aber: Wenn ich beide Platten angeschlossen hab, bootet der Rechner von der IDE-Platte (völlig egal, ob ich zum Booten nur HDD-0 oder nur HDD-1 im BIOS einstelle). Soweit noch in Ordnung denn dort befindet sich ja der Bootmanager, der dann geladen wird. Wählt man Linux, startet alles ganz normal. Will man aber Windows starten, kommt nur das hier:

post-11102-1164631032_thumb.jpg

Um Windows zu starten, muss ich darum immer die IDE-Platte abstecken.

Jetzt die Preisfrage: Was hab ich falsch gemacht? Mit Sicherheit stimmt irgend ne Einstellung für den Bootmanager nicht, aber wie kann ich das reparieren?

(Möglichst ohne SuSe neu zu installieren ;) )

mfg

Share this post


Link to post
Share on other sites

Deine SATA hängt an nem anderen Controller als die IDE. Der Unterschied sollte größer sein als HDD0/HDD1.

Was kann dein Bios noch außer HDD0 und HDD1? Versuch im YAST den Bootloader über automatische Erkennung neu zu konfigurieren. Aber nur Speichern wenn er was Sinnvolles erkennt.

> Sichere Dein XP und installiere den Bootmanager auf der XP-Platte, das sollte klappen.

Solange das Bios nur von SATA hochfährt, wenns die einzige Platte ist, macht das wenig Sinn.

Edited by AndOrth

Share this post


Link to post
Share on other sites

e:

also ich hab nochmal rumprobiert und immerhin herausgefunden, dass der SATA-Controller als SCSI bezeichnet wird... warum auch immer...

Auf jeden Fall stimmt die Bootsequenz, sonst hätte ich ja keinen Bootloader.

Macht es wirklich nen Unterschied, auf welcher Platter der installiert ist? Ich dachte das ist egal Oo

Ich schau grad mal was sich mit yast machen lässt...

mfg

Edited by Dr. Dünnpfiff

Share this post


Link to post
Share on other sites

Versuch mal den Bootloader auf ne Diskette zu packen. Du benutzt wahrscheinlich Grub. Damit hatte ich auch schon meine Probleme...wenn das nicht hilft, probiers mit Lilo :)

Share this post


Link to post
Share on other sites

Jop, hab eigentlich immer Grub benutzt :)

Hab mal eben zwei Screens gemacht, wie es momentan aussieht.

Hab dazu zwei vielleicht n wenig blöde Fragen^^

Kann ich den Bootloader einfach so auf die Windows-Platte installieren oder gibts da irgendwelche Risiken? Weil Datensicherung is grad schlecht, ich hab keine so große HDD mehr um mein Windows zu sichern...

Und zweitens: Wenn ich das mache, kann ich Linux nicht mehr starten, wenn die Windows-Platte abgeklemmt oder formatiert ist?

Hatte sonst halt immer entweder nur Linux auf nem Rechner oder beides auf einer Platte und dann auch immer beides gleichzeitig neu installiert; da kümmert man sich eher weniger um sowas^^

mfg

post-11102-1164652206_thumb.jpg

post-11102-1164652219_thumb.jpg

Share this post


Link to post
Share on other sites

wenn du einen Linux-Bootloader auf eine Windowspartition oder Festplatte installierst, wird der MBR überschrieben. Das kann in Einzelfällen dazu führen, dass Windows sich nie wieder auf der Festplatte starten lässt. Es ist also immer ratsam getrennte Partitionen besser noch getrennte Festplatten für die Betriebssysteme zu verwenden.

Naja, wenn der Bootloader auf der Windowspartition ist, dürfte klar sein, dass wenn sie nicht angesteckt ist, Linux nicht starten kann. Ich empfehle dir wirklich den Bootloader auf eine Diskette zu installieren. So zerstörst du nicht den MBR und kannst jederzeit dein System wieder in den alten Zustand bringen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.