Jump to content
Shadow Ratchet

Problem beim Starten meines Servers (Linux)

Recommended Posts

Hallo.

Ich ärgere mich seit 2 Tagen mit meinem BF2-Server rum. (Wofür sind alte Rechner doch noch gut :P)

Die Version ist 1.5.3153.0.

Es will einfach nicht funktionieren und ich habe schon alles was ich irgendwie finden konnte gelesen.

Hilft aber nichts....

Zu den PC Daten und Linux usw.:

Linux openSUSE 11.1

AMD Athlon XP 2400+ (1,67 GHz)

512 MB RAM

GeForce 6600 GT

Ich habe begonnen indem ich mir zuerst einen neuen User "battlefield" erstellt habe.

Dazu dann noch gleich einen Homeordner.

Darin besteht Vollzugriff.

Dann habe ich mir die "bf2-linuxded-1.5.3153.0-installer.sh" gezogen und ausführbar gemacht.

Danach ausgeführt.

EULA und Punkbuster abgenickt.

Verzeichniss /home/battlefield ausgewählt.

Bis dahein klappt alles!

Dann die serversettings.con angepasst (Name, ServerIP, InterfaceIP, Runden pro Karte, Wilkommensnachricht, etc.)

Die maplist.con angeschaut -> Karkand mit 32 Spielern reicht mir erstmal zum Testen^^

Dann wieder in den /home/battlefield/bf2 Ordner gewechselt und "screen -dmS bf2 ./start.sh"ausgeführt.

Da bekam ich das Problem:

error while loading shared libraries: libstdc++.so.5: cannot open shared object file:Datei oder Verzeichniss nicht vorhanden
Gegoogelt: Oh ich muss da ein paar libstdc++ nachinstallieren. Gesgat getan! Und Fehler war weg. Und nochmals die "screen -dmS bf2 ./start.sh"ausgeführt. Da passiert nichts und ich springe in die nächste Zeile. Wenn ich nur "./start.sh" ausführe passiert erst nichts dann kommt gan ganz kurz ein leeres Terminal und dann bin ich in der nächsten Zeile... Führe ich nur "screen ./start.sh" aus kommt das:
FATAL ERROR: Debug assertion failed!



									Version: 1.5.3153-802.0 Build date:implement unix date here

																							   Module: GameServer

																												 File: Game/GameServer/GameServer.cpp

								Line: 647



										 Text: 0xbfd1d298



														 Current confile:

Und ich komme so einfach nicht weiter.

Google spuckt dazu nichts aus.

Und ich habe es gestern (weiß abe rnicht mehr wie, es geschafft das der Server lädt...)

Und Neuinstallation bringt auch nichts.

Kann mir wer helfen???

Grüße Shadow Ratchet.

(Falls es hier doch falsch sein sollte: Sorry bin neu im Forum :P)

Link to comment
Share on other sites

lösch noch mal alles davon und installiere bf2 wieder. dann machste den ersten start aber OHNE screen. dann läßte den starten und beendest ihn, nachdem er FRETIG geladen ist.

dann würde ich noch BF2CC(D) instalieren zur besseren administration des systems bzw des servers.

Link to comment
Share on other sites

Okay ich habe mir jetzt die neuste Version Ubuntu besorgt und installiert.

Auch zur Vorsicht den Dedicated Server auch nochmal neu gezogen.

Installiert.

sh start.sh ausgeführt - libstdc++.so.5 Fehler. Naja auf der Ubuntu Seite ein passendes Packet gefunden insatlliert. Doch wenn ich mal wieder sh start.sh (oder halt ./start.sh) ausführe kommt kurz ein schwarzer Bildschrim und dann ab in die nächste Zeile.

Wenn ich den Befehl screen -dmS bf2 sh start.sh (oder nur screen sh start.sh) eingebe kommt nur kurz die Meldung.

[Screen is terminating]

Kann mir wer helfen?

Liegt es an glibc?

Normalerweise ist da sja in den libstdc++.so.6 enthalten (die sind bei mir auch vorhanden)

Es ist echt doof :(

Oder bin ich wirklich soooo doof, und kapiere es nicht, dass ich vorher Version 1.41 aufspielen muss und dann erst Version 1.5?

So wie beim Game-Patch?

Also Leute helft mir mal :daumenhoch:

Greets

Edited by Shadow Ratchet
Link to comment
Share on other sites

Ja! Es hat geklappt!

Ich musste in der serversettings.con einfach die interne IP angeben und bei sv.allowNATNegotiation eine 1 schreiben.

Ich habe beim Router die Ports weitergeleitet.

Doch wenn ich auf meinen Server connecten will werde ich nach einer Minute mit der Fehlermeldung

"Deine Verbindung zum Server wurde unterbrochen." rausgeworfen.

Zudem zeigt er manchmal den Port beim Laden gar nicht mit an sondern nur :0 manchmal aber auch richtig und manchmal auch nur :0

Weiß da jemand wie ich es verhindere, dass ich dauernd die Verbindung verliere?

Edited by Shadow Ratchet
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.