Jump to content

Archived

This topic is now archived and is closed to further replies.

hunter137(ger)

bf42/fh0.7 lädt nicht im Win98/ME Kompatibilitätsmodus unter Windows 7

Recommended Posts

Hallo zusammen,

ich bin von Windows XP auf Windows 7 Professional 64bit umgestiegen. Während in XP fh0.7 tadellos funktionierte bricht es in Win7 beim laden einer map ab.

Als generelle Lösung wird überall erwähnt das man bf1942.exe im Windows 98 / Windows ME Kompatibilitätsmodus starten soll.

Genau hier setzt mein Problem an:

Wenn ich bf1942.exe auf win98/me kompatibilität stelle und das ganze als administrator ausführe startet das spiel überhaupt nicht, die .exe ist für ca. 3 sek im Task manager zu sehen und verschwindet dann wieder - ich erhalte keine (Fehler)Meldung.

Kann mir hier jemand helfen?

(Noch eine Anmerkung bf42 selbst kann ich ohne probleme spielen - ohne Kompatibilitätsmodus)

Share this post


Link to post
Share on other sites

Ich habs grad mal installiert und ein bisschen herumgefrickelt.

Die BF1942.exe & Blackscreen.exe hab ich im Win98-Mode und als Administrator ausgeführt (Haken unten auf gleichem Tab gesetzt).

Ich hab nicht getestet, ob die Blackscreen.exe auch so laufen muss aber da sie beim Kartenwechsel läuft,

ist das vielleicht schon nötig. Und ich habe generell die UAC (Benutzerkontensteuerung) deaktiviert.

OS: W7 x64

Also, nochmal probieren. Es müsste funken. :daumenhoch:

€: n paar Worte vergessen. Hm.

Share this post


Link to post
Share on other sites
Ich habs grad mal installiert und ein bisschen herumgefrickelt.

Die BF1942.exe & Blackscreen.exe hab ich im Win98-Mode und als Administrator ausgeführt (Haken unten auf gleichem Tab gesetzt).

Ich hab nicht getestet, ob die Blackscreen.exe auch so laufen muss aber da sie beim Kartenwechsel läuft,

ist das vielleicht schon nötig. Und ich habe generell die UAC (Benutzerkontensteuerung) deaktiviert.

OS: W7 x64

Also, nochmal probieren. Es müsste funken. :daumenhoch:

€: n paar Worte vergessen. Hm.

Ganz genauso hab ichs eben nochmal ausprobiert - nichts passiert, 2-3 sek ladezeichen am Mauszeiger und dann nichts mehr.

Share this post


Link to post
Share on other sites

Hast du mal alle anderen Dateien gecheckt, ob die noch in irgendwelchen Modi laufen?

Es gibt irgendwo nen Registry-Hive, in dem alle Dateien mit speziellen Modi aufgelistet werden.

Ich glaube der hier:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

oder der hier:

HKEY_USERS\S-1-5-21-2780948896-3898155159-3276323797-1000\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

Da kannst du mal nachschauen, was alles so in welchem Modus läuft.

Sonst weiß ich nicht weiter. Das Problem liegt dann leider definitiv an deiner Konfiguration.

Aber lösen läßt sich das schon.

€dit: Big drama! :o Jetzt funkts bei auch nich mehr. Hölle! :wtf:

Vielleicht kann ja jemand anders noch Erfahrungen beisteuern. Ich such weiter.

Share this post


Link to post
Share on other sites

Es stehen halt bf1942.exe und die blackscreen.exe als "win98 runasadmin" nebst anderen programmen.

Aber mit Registry kenne ich mich ehrlich gesagt nur schlecht aus.

Share this post


Link to post
Share on other sites

Ja. Passt. So hatte/hab ich es auch. Aber nu willa nich mehr. Ich könnt sowas von... :allesklar:

Nur Geduld. Da findest sich schon ne Lösung.

€: Es ist echt zum Mäusemelken. Das ist ja auch nur bei FH so, oder? Ich hab grad x Mods probiert und alles ging.

Ich hab BF übrigens nicht in C:\Program Files(x86) sondern in C:\Games installiert,

da nur dort alle Schreibrechte verfügbar sind. Menno. Sry.

Share this post


Link to post
Share on other sites

So. Halt dich fest: es geht wieder. Und ich hab nix geändert, außer kurz die Kompatibilitätseinstellungen rausgenommen und wieder so wie zuvor eingestellt. Strange.

Was vielleicht helfen könnte: BF42 direkt per Exe oder per Verknüpfung auf die Exe starten und erst im Menü

unter "Eigene Spiele" o.ä. FH aktivieren. Es scheint so n bisschen Glückssache zu sein. Ich meld mich wieder, wenn ich genaueres weiß.

Hat jemand noch flott nen Tipp, wie man die Auflösung ändert? Ich hab momentan 1280x960, hätte aber gern 1280x1024.

Is aber erst mal egal. Das find ich schon.

Share this post


Link to post
Share on other sites

Hab ich auch ausprobiert was Du beschreibst. Sobald ich die Kompatibilitätseinstellungen wieder einschalte startet das Programm nicht, ich komme dann also auch in gar kein Menü...

Was die Auflösung angeht, könnte Dir das hier helfen(hat bei mir in XP geklappt) hab aber munkeln hören das das bei Win7 wegen kompatibilität nicht mehr funzt.

http://www.bf-games.net/forum/index.php?showtopic=42463

Share this post


Link to post
Share on other sites

Fett danke. Ich hab schon ein bisschen mit der Auflösung gefrickelt.

Momentan startet hier auch nix. Eben ging es noch. Es ist zum Mäusemelken.

Share this post


Link to post
Share on other sites

Ich habe mir einen neuen Benutzer angelegt unter Windows und dort bf42 neu installiert, JETZT kann ich im win98/me komp. modus starten bei BF klappts auch aber FH bricht wieder während map laden ab. Die Lösung war das noch nicht aber ein kleiner Schritt hoffe ich. Weiß jemand mehr?

Share this post


Link to post
Share on other sites

Nun will ich mal diesen fast 1 Jahr alten Thread beleben

Auf meinem alten Recher (mit Win Vista) funktionierte das mit dem 98er Kompatiblitätsmodus, jetzt habe ich jedoch einen neuen Rechner mit Win 7. BF 1942 klappt auch, allerdings will FH nicht laufen (mit dem altbekannten Fehler).

Gibts inzwischen dafür eine Lösung oder kann ich FH endgültig abschreiben?

Nachtrag:

FHSW geht (zumindest in einer veralteten Version, die neuste teste ich morgen)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.