Jump to content

Archived

This topic is now archived and is closed to further replies.

rhoads

Schwarzer Bildschirm im Spiel (Windows 7 32-bit)

Recommended Posts

Hallo Leute,

bin neu hier und ich hab mir gestern BF 1942 WWII Anthology gekauft, is halt BF 1942 mit Add-ons. Ich hab Windows 7 32-bit und habs problemlos installieren können und kann auch alle Teile problemlos starten. Nur wenn dann das Intro vorbei ist und man eigentlich ins Menü gelangen sollte, kommt ein schwarzer Bildschirm -.- Man hört zwar die Musik im Hintergrund! (kenn ich noch von früher) aber dann stehts an und nichts passiert mehr!

Wär klasse wenn mir einer weiterhelfen könnte ;)

danke im Vorraus rhods ;);)

Share this post


Link to post
Share on other sites

also ich hab jetzt mal alles ausprobiert was ich da gefunden hab .. funzt immer noch nicht :(

komisch is auch, dass ich das spiel im kompatibilitätsmodus nicht starten ..

hier noch ein paar infos zum system: Windows 7 Ultimate 32-bit

AMD Turion X2 Dual-Core Mobile RM-72 2.10 GHz

4,00 GB Arbeitsspeicher

NVIDIA GeForce 9800M GS

Share this post


Link to post
Share on other sites
...\EA GAMES\Battlefield 1942\Mods\bf1942\Settings\VideoDefault.con

Folgende Zeile einfügen bzw. die wohl eingetragene 0 in eine 1 ändern.

renderer.allowAllRefreshRates 1

Sicher das du die richtige Datei bearbeitet hast ?

Eventuell mal Schreibschutz aktivieren nach dem Bearbeiten.

Der schwarze Bildschirm nach dem Intro ist wirklich zu 100% in meiner BF42-Historie auf diesen "fehlerhaften" Eintrag zurückzuführen. :kritisch:

Welche Patches hast du installiert ?

Die Anthology-Version benötigt nur den letzten Patch.

http://www.bf-games.net/download/315/battl..._notwendig.html

Zu WIN7 [ich benutze die 64-bit Pro Version]

....

BlackScreen.exe

BF1942.exe

PnkBstrB.exe

Mit Adminrechten ausstatten und [für die BF1942.exe] XP ServicePack2 oder 3 Kompatibilätsmodus einstellen. (bei manchen auch 2000 oder 98/ME). Bei mir funktioniert es so eventuell mußt du ein paar mal probieren zu connecten war bei mir auch so bis ich die für meine WIN-Installation richtige Einstellung gefunden habe scheint immer etwas anders zu sein je nach Kiste....

Ich habe bei mir auch UAC [benutzerkontensteuerung] ausgeschaltet vielleicht ist das noch eine Hilfe

Share this post


Link to post
Share on other sites

@Buggy McDermit:

Sorry aber ich muss dich leider wieder enttäuschen, hab gleich den Patch 1.61 runtergeladen .. nix geändert:(

Dann hab ich noch nochmal die Settings Datei angesehn, aber bei der passt alles, hab dir sogar noch die Werte kopiert renderer.setFullScreen 1

renderer.fieldOfView 1

renderer.globalLodRadius 1

renderer.globalLodRadiusScaleFactor 5

console.showStats 0

renderer.allowAllRefreshRates 1

Hmm ja is gut und recht, dass du die 64-bit version benutzt, nur ich kann sie leider nicht benutzen :(

Nur dass einzige was ich nicht verstehe, is der Kommentar im lezten Fenster .. kann man da XP Service Packs auf Win7 installieren oder wie? :/

Share this post


Link to post
Share on other sites

Rechte Maustaste auf die Datei --> Eigenschaften

Dort kannst du den Kompatibilätsmodus einstellen unter dem Reiter Kompatibilität bei WIN 7.

Solltest du einen "Refresh Rate Locker" [bspw. RefreshForce] benutzen muß der ausgeschaltet sein.

Ansonsten könnte so eine Einstellung in deinem Grafikkartentreiber aktiviert sein und den Fehler verursachen habe aber keine Geforce daher weiß ich nicht wo das dort stehen könnte.

renderer.usetrilinearfiltering 1

Könntest du nochmal in die Settings Datei einfügen und probieren ob es geht falls nicht wieder rauslöschen.

Share this post


Link to post
Share on other sites

also endlich gute nachriten :) bf funzt !!! :)

ich hab jetzt Win 2000 kompatiblität eingestellt und diese Zeile renderer.usetrilinearfiltering 1 in die VideoDefault Datei eingefügt und plötztlich läufts :)

also nochmals vielen vielen dank :)

mfg rhoads

Share this post


Link to post
Share on other sites

leider zu früh gefreut :( das spiel hat genau einmal gestartet :trollface:

wollts vorhin wieder starten und plötzlich ging nix mehr .. das spiel welchest in den Vollbildmodus und dann kommts sofort ein black screen und dann is ende

hab jetzt schon sämtliche kompatiblitäten durchprobiert und die zeile aus der VideoDefault Datei is auch schon rausgelöscht .. geht noch immer nix :(

Share this post


Link to post
Share on other sites
leider zu früh gefreut :( das spiel hat genau einmal gestartet :trollface:

wollts vorhin wieder starten und plötzlich ging nix mehr .. das spiel welchest in den Vollbildmodus und dann kommts sofort ein black screen und dann is ende

hab jetzt schon sämtliche kompatiblitäten durchprobiert und die zeile aus der VideoDefault Datei is auch schon rausgelöscht .. geht noch immer nix :(

Die Datei schreibgeschützt setzen, deswegen ging es auch nur einmal, da hat BF "seine" Werte wieder drübergeknallt.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.