Jump to content
Mattjes

bf2 startet unter windows 7 nicht

Recommended Posts

Moin. Wie der Themennahme schon sagt startet bf2 bei mir nicht mehr richtig.

ich hatte zuvor Vista auf meinem Laptop, da lief bf2 problemlos, habe dann jedoch formatiert und Win7 Professional (32 bit) draufgemacht. Dann habe ich bf2 isntalliert samt allen Patches. Wenn ich das Spiel starte, wird der Bildschirm kurz schwarz, doch dann lande ich wieder aufm Desktop.

Ich hab schon alles versucht, was in anderen Themen zu diesem problem stand, also als Admin gestartet, die Kompitabilitätsmodi umgestellt, als Admin bf2 installiert (nicht ins standart-verzeichnis) usw., jedoch es ist immer das selbe.

Wie gesagt unter Vista lief alles Problemlos, es liegt also an Windows 7 (32 bit).

Ich hoffe jemand kann mir helfen. :)

Edited by Mattjes
Link to comment
Share on other sites

Als Administrator Ausführen sollte helfen, setzte vorsichtshalber noch den Kompatibilitätsmodus auf WinXP/SP3 ;)

Das hat bei mir geholfen, benutze auch Win7 32 Bit

Ansonsten installiere mal neu eventuell gab es bei der installation Probleme, da Win7 sich nur ungern an der "C" Platte rumpfuschen lässt.

Edited by Shifty 16
Link to comment
Share on other sites

Guest -(HC83)-

Hast du für die Startparameter in die Verknüpfung etwas eingefügt? Laptops haben doch andere Auflösungen.

"BF2.exe" +menu 1 +fullscreen 1 +szx 1680 +szy 1040 in etwa so,nur halt deine Auflösung...

edit: evtl. +widescreen 1 noch mit dran machen.

Edited by -(HC83)-
Link to comment
Share on other sites

Danke erstmal für die schnellen Antworten :)

Als Administrator Ausführen sollte helfen, setzte vorsichtshalber noch den Kompatibilitätsmodus auf WinXP/SP3 ;)

Das hat bei mir geholfen, benutze auch Win7 32 Bit

Ansonsten installiere mal neu eventuell gab es bei der installation Probleme, da Win7 sich nur ungern an der "C" Platte rumpfuschen lässt.

Als Administrator ausführen bringt leider nichts, die Kompatibilitätsmodi hab ich schon alle durch.

Bf2 hab ich auch auf D installiert.

Hast du für die Startparameter in die Verknüpfung etwas eingefügt? Laptops haben doch andere Auflösungen.

"BF2.exe" +menu 1 +fullscreen 1 +szx 1680 +szy 1040 in etwa so,nur halt deine Auflösung...

edit: evtl. +widescreen 1 noch mit dran machen.

Glaub kaum, dass das was damit zu tun hat. Wie gesagt hat bf2 unter Vista einwandfrei funktioniert. Außerdem besteht das selbe Problem, wenn ich bf2 über die exe direkt starte. Ich habs jetzt trotzdem mal in die Verknüpfung reingeschrieben, doch es hat leider nichts gebracht.

Ein Freund von mir hat auch Windows 7 (aber 64 bit) und bei dem Funktioniert alles.

Ich hoffe jemand kann mir helfen :)

Link to comment
Share on other sites

- im Fenstermodus starten für eventuelle Fehlermeldung

- in den Video.con-Dateien in Eigene Dokumente\Battlefield 2\ schauen, was dort für Auflösungen u.v.a. Bildwiederholraten angegeben sind. Zur Not, nach nem Backup, alle Video.con löschen

- manuell die entsprechende HZ einstellen

Wenn du den gesamten Ordner von Vista rüberkopiert hast, entstehen manchmal Probleme mit den Zugriffsrechten auf diese Dateien. Das mal checken aber ich glaub nicht, dass es daran liegt.

W7 macht nur Probleme, wenn Sachen in C:\Program Files oder C:\Program Files (x86) installiert werden. Letzteres betrifft natürlich W7 x64.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.