Jump to content
Sign in to follow this  
web

BF2 linux auf Debian70 OS

Recommended Posts

Hi,

hat das schon mal einer hinbekommen ?

 

Das Problem ist dort das installen von  "mono-1.1.12.1_0" (diese ist excat die einzige mono Version unter der BF2CC läuft).

 

Der Installer (mono) lässt sich unter debian70 nicht zum starten bewegen (chmod werte entsprechend gesetzt).

Bei debian60 bzw. genauer 6.0.7 klappt das noch einwandfrei - (eben getestet auf nem lokalen system).

 

Irgend jemand nen Tip wie man das hinbekommen kann ???

- denn sonst siehts in nächster Zeit echt düster mit BF2 installationen auf linux aus - vor allem wenn die Hoster nur noch Debian70 oder höher supporten bzw. zum installen anbieten...

 

cu Web

 

Share this post


Link to post
Share on other sites

Was kommt den für eine Fehlermeldung?

 

 

:EDIT:

 

Ich habe das auf meinem Server hier mal probiert.

Das ist ein 64bit AMD System.

 

Mono lies sich zwar sauber installieren, aber nicht starten, wie bei dir.

Dafür habe ich diese Fehlermeldung bekommen:

 

mono-1.1.12.1/bin/mono: error while loading shared libraries: libgthread-2.0.so.0: cannot open shared object file: No such file or directory

 

Ich habe noch die Libs, allerdings für i386 installieren müssen.

Dazu war ein:

 

sudo dpkg --add-architecture "i386"
 

dann ein

 

sudo apt-get update

ein

 

sudo apt-get upgrade

 

und

 

sudo apt-get install ia32-libs-gtk

(ggf. noch ein apt-get install ia32-libs-i386 falls es nicht klappt)

 

Anschließend lacht mich ein:

 

gameserver/mono-1.1.12.1/bin/mono bf2ccd.exe -playerlimit 64 -locknetsettings -autostart
BF2CCD Initalized.  Use 'mono bf2ccd.exe -help' for additional options.

an.

 

Viel Spass ;)

 

PS: Neustarten würde ich vorher nochmal zu Sicherheit.

 

 

 

Ich hoffe das ich dir helfen konnte. Ansonsten kannst du dich gerne nochmal melden.

 

Gruß Spion

Edited by Spion

Share this post


Link to post
Share on other sites

Thanks fur den reply....

 

also fehlermeldung kommt keine ...

schon der normale install anstoss mittels "./mono-1.1.12.1_0-installer.bin" funktioniert da aufm server nicht (Chmod 755 "xxxxxxxxx-bin" vorher ist gemacht und wird auch bestätigt)

Der cusor springt ne zeile weiter und das wars... und es ist egal von wo aus ich das versuche - bin ja als root auf nem frisch aufgesetzten server drin (via SHH2)

 

Normalerweise sollte ja je nachdem was man benutzt (desktop oder console) zumindest etwas passieren - machts aber nicht...

normal aufm Desktop - da popt der installer hoch (macht er bei mir jedenfalls aufm lokalen rechner - und man muss klicken) bei der console kommen normal div. y/n Abfragen - aber nix der installer staret nicht mal.

 

Desktop debian version 6.0.7

server console  ebenso

 

Bis jetzt hab ich aufm Server folgende debian versionen versucht - 7, 6.07 und bei 5 bin ich gerade dran (alles jeweils als LAMP 64-bit).

 

nachtrag - die 5er lamp 64-bit hängt schon beim restart fest, kann aber nicht checken ohne zugriff woran das liegt - der server ist bei Hetzner gemietet und die supporten nur noch die 7er version alles darunter nicht mehr :( .

 

 

cu web

Edited by web

Share this post


Link to post
Share on other sites

Mit der 7er 64bit muss es gehen. Kann also nicht am System liegen.

 

Versuch es mal mit chmod +x mono-1.1.10_1-installer.bin

 

Hast du mono auch mal neu runtergeladen?

Share this post


Link to post
Share on other sites

also - geht net....

die hier "mono-1.1.10_1-installer.bin" sowie so nicht - die "mono-1.1.12.1_0-installer.bin" wäre richtig.

Und ja immer alles neu gezogen...

dann "chmod +x mono-1.1.12.1_0-installer.bin -v"   => "mode of `mono-1.1.12.1_0-installer.bin' retained as 0755 (rwxr-xr-x)"
wenn man dann mit "./mono-1.1.12.1_0-installer.bin" es versucht, springt der nur ne zeile weiter und das wars.

 

Und wie bereits geschrieben ich bin als root drin auf nem frischen install via SSH2 (also putty) - "sudo" brauchts da nicht - bei debian (egal was)  ->  also NICHT wie bei "ubuntu" oder ähnlichem !

 

Mit dem befehl kann das os "debian6.0.7" nix anfangen ->"dpkg --add-architecture "i386"" bzw gibt dpkg nen error raus wenn man das versucht.

Edited by web

Share this post


Link to post
Share on other sites

Lass die "" weg. War ein Tippfehler von mir. Das brauchst du aber sowieso erst, wenn mono fehler ausgeben sollte.

 

Wenn du nur als "root" arbeitest, installierst du den dann auch als root und startest den bf-server als root?

 

Ich bin hier von einem Debian7 wheezy 64bit AMD System ausgegangen, auf dem ich sudo, da ich vorwiegend als user arbeite installiert habe.

Also nichts mit "Ubuntu" oder ähnlichem.

 

Ich habe meine .bin mit "chmod 700 mono-1.1.12.1_0-installer.bin" ausführbar gemacht.

 

 

Ansonsten installier dir das mono lokal auf dem Rechner, und schieb es hoch.

Dann die Berechtigungen im monoordner von Hand setzen.

 

Am Ende noch in die .bashrc vom entsprechendem user

 

export PATH="/home/username/mono-1.1.12.1/bin:$PATH"

export PKG_CONFIG_PATH="/home/username/mono-1.1.12.1/lib/pkgconfig:$PKG_CONFI$

export MANPATH="/home/username/mono-1.1.12.1/share/man:$MANPATH"

export LD_LIBRARY_PATH="/home/username/mono-1.1.12.1/lib:$LD_LIBRARY_PATH"
 

eintragen. Dann sollte es gehen.

Share this post


Link to post
Share on other sites

na was soll ich sagen .... linux das - irre teil -

so klappts auf einmal (in der Reihenfolge) als "root" im root des Servers oder im "root" Verzeichnis selbst...

1. "apt-get install ia32-libs-gtk"
2. "apt-get install ia32-libs-i386"
3. "apt-get update"
4. "apt-get upgrade"
5. "./mono-1.1.12.1_0-installer.bin"
5a. => "Do you accept this license? [Y/n]" = "Y" oder "[Enter]"
5b. => "Installation Directory [/opt/mono-1.1.12.1]" = optionales Verzeichnis (eventuel günstig damit ein eventuelles Mono Update die für BF2 benötigten Files nicht überschreibt)
5c. => "The directory /opt/mono-1.1.12.1/bin needs to be added to your path in order to run Mono. Setup will modify your ~/.bashrc, ~/.profile files as required. Alternatively you can choose 'No' below, and add the directory manually after installation. [Y/n]:" = "Y" oder "[Enter]"
5d. => "Do you want to continue? [Y/n]" = "Y" oder "[Enter]"
5e. => "installing 0% ... 100%" "Setup has finished installing Mono on your computer"
5f. => "View Readme file? [Y/n]" = "Y" oder "[Enter]"

 

allerdings gibts jetzt noch das hier "mono -V" zeigt z.Zt. nur "-bash: mono: command not found". Werde den Server mal neu starten....

Share this post


Link to post
Share on other sites

Welche Debianversion benutzt du jetzt?

 

Denk dran, sowas nicht als root laufen lassen.

 

Um mit mono zu arbeiten, musst du mono noch sagen wo es installiert ist. Da es nicht über die Packetverwaltung gekommen ist.

 

Also z.B. so:

 

/home/username/mono-1.1.12.1/bin/mono bf2ccd.exe -serverparameter

Share this post


Link to post
Share on other sites

Debian 6.0.7 64-bit (LAMP) und damit renns ja auch...

Das mit dem root ist schon klar [;)] hab den Server nicht erst seit gestern - der lief ja 1.5 Jahre ohne Probs mit zeitweise 15 BF2 games....

Nur letztens hat mir Plesk alles zerschossen, weils beim updaten alles entfernt hat - das lt. Plesk Meinung da nix drauf zu suchen hat....

Also alles neu machen (Plesk kriegt man zwar deaktiviert - aber nicht mehr sauber runter) also weg damit.

Trotz alle dem herzlichen Dank für deine Hilfe...

cu web

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.