Jump to content
Sign in to follow this  
Niko280399

Kick durch PunkBuster

Recommended Posts

Hallo, es wurden schon viele Beiträge zu diesem Thema erstellt aber ich finde ienfach keine Lösung. 
Werde immer innerhalb von spätestens 1 min von Punkbuster rausgeworfen. 

Danach dieser Feher im Battlelog: 
FEHLER 
Verbindung zum Spiel unterbrochen: Du wurdest von PunkBuster rausgeworfen. (Grund: PunkBuster kicked player 'l4st4live' (for 0 minutes) ... No Packet Flow)
 

PunkBuster schon mehrere male neu installiert und auch diesnt manuell gestartet oder sonstiges. 
Firewall ist ganz normal an oder am Virenschutz kann es auch nicht liegen. 

Das komische ist, das Problem ist einfach aus dem Nichts aufgetaucht, BF3 hat davor einwandfrei funktioniert.

Share this post


Link to post
Share on other sites

Ist der Dienst (PnkBstrA&B.exe) denn gestartet? Btw kann du mal versuchen TCP/IPv6 im Netzwerk Adapter zu deaktivieren. Dann am besten mal PC neustarten und nochmal probieren und wieder bescheid sagen.

 

Und Portweiterleitung auf 3659 setzen. UDP/TCP.

Edited by Th3Z0n3

Share this post


Link to post
Share on other sites

Beide Dienste sind gestartet und auf automatisch ausführen. Habe TCP/IPv6 deaktiviert aber ändert nix...

Hab den Port auf 3659 gesetzt, aber keine besserung :(

Share this post


Link to post
Share on other sites

No paket flow heitß, keine Daten kommen an den Server, also irgendetwas blockt. Könnte ein Firewall- (oder Virenscanner-) problem sein. Portweiterleitung (nach innen zum PC) ist nicht notwendig.

Share this post


Link to post
Share on other sites

Lade Dir mal "pbsvc" -> http://www.evenbalance.com/index.php?page=faq-generic.php runter und lass es mit Admin Rechten (Test services) laufen.

Es meldet Dir eventuelle Fehler in der Verbindung und loggt diese mit....

Beispiel log (win7 64-bit) :

 

Starting PunkBuster Service Tests (v0.993) (02/07/15 09:48:27)
Checking OS
  Windows NT 6.1 (build 7601, Service Pack 1) 64-bit
Checking PnkBstrA service status   RUNNING
Checking PnkBstrA Version          OK (1036)
Extracting "PnkBstrB.exe" to:
   "C:\Users\Administrator\AppData\Roaming\PnkBstrB.exe"
                                   OK
Checking firewall settings         OFF
Is PnkBstrA explicitly allowed?
C:\Windows\system32\PnkBstrA.exe   NO
Is PnkBstrB explicitly allowed?
C:\Windows\system32\PnkBstrB.exe   NO
Checking if PnkBstrB is running    NOT RUNNING
Getting port for PnkBstrA          OK (44301)
Opening socket for packet send     OK
Sending version packet to PnkBstrA SENT
Receiving version from PnkBstrA    OK
Received 6 bytes from 127.0.0.1:44301
  Response = 10983 (ms) Version = v1036
Getting PnkBstrB install instance  OK
Sending start packet to PnkBstrA   SENT
Waiting for packet from PnkBstrA   OK
Received 3 bytes from 127.0.0.1:44301
  Response = 15351 (ms) PnkBstrB started.
  Load SUCCESSFUL.
Watching for PnkBstrB instance change (3840) CHANGED (3841)
Getting port for PnkBstrB          OK (45301)
Sending version packet to PnkBstrB SENT
Receiving version from PnkBstrB    OK
Received 5 bytes from 127.0.0.1:45301
  Response = 3276 (ms) Version = 2202
Checking PnkBstrK driver status    NOT FOUND
Manually stopping PnkBstrB         STOPPED
Removing test PnkBstrB file        OK

----------------------------------
  Tests finished.
 

Deins sollte so ähnlich aussehen.

Edited by web

Share this post


Link to post
Share on other sites
 
So sieht mein Test aus...
 
(02/07/15 17:13:06)
Checking OS
  Windows NT 6.1 (build 7601, Service Pack 1) 64-bit
Checking PnkBstrA service status   RUNNING
Checking PnkBstrA Version          OK (1041)
Extracting "PnkBstrB.exe" to:
   "C:\Users\Niko\AppData\Roaming\PnkBstrB.exe"
                                   OK
Checking firewall settings         OFF
Checking if PnkBstrB is running    NOT RUNNING
Getting port for PnkBstrA          OK (44301)
Opening socket for packet send     OK
Sending version packet to PnkBstrA SENT
Receiving version from PnkBstrA    OK
Received 6 bytes from 127.0.0.1:44301
  Response = 11949 (ms) Version = v1041
Getting PnkBstrB install instance  NOT FOUND
Sending start packet to PnkBstrA   SENT
Waiting for packet from PnkBstrA   OK
Received 3 bytes from 127.0.0.1:44301
  Response = 16364 (ms) PnkBstrB started.
  Load SUCCESSFUL.
Watching for PnkBstrB instance change (0) CHANGED (1)
Getting port for PnkBstrB          OK (45301)
Sending version packet to PnkBstrB SENT
Receiving version from PnkBstrB    OK
Received 5 bytes from 127.0.0.1:45301
  Response = 2995 (ms) Version = 2333
Checking PnkBstrK driver status    NOT FOUND
Manually stopping PnkBstrB         STOPPED
Removing test PnkBstrB file        OK
 
----------------------------------
  Tests finished.

Share this post


Link to post
Share on other sites

Also läuft doch PB bei Dir einwandfrei... es kann nur nichts an PB(evenbalance) senden.

 

Folgende Progs. von PB sollten in der Firewall immer auf Durchzug stehen - gemeint ist - nicht geblockt werden :

pbsetup.exe ->TCP + UDP jeweils alle Ports, ein und ausgehend;

pbsvc.exe ->TCP + UDP jeweils alle Ports, ein und ausgehend;

(C:\Windows\SysWOW64\PnkBstrA.exe) PnkBstrA.exe ->TCP + UDP jeweils alle Ports, ein und ausgehend;

(C:\Windows\SysWOW64\PnkBstrB.exe) PnkBstrB.exe ->TCP + UDP jeweils alle Ports, ein und ausgehend;

Share this post


Link to post
Share on other sites

Folgende Progs. von PB sollten in der Firewall immer auf Durchzug stehen - gemeint ist - nicht geblockt werden :

 

Firewall hab ich komplett mal ausgeschaltet aber bringt bei mir auch nichts.... 

Share this post


Link to post
Share on other sites

Hast du nen Router an der Leitung  ? - Settings sichern - auf Werkeinstellung resetten und dann mal testen...

 

Und /oder Kabelmodem in Verwendung ? - mal Router + KModem 1-2 min. vom Stromnetz trennen - anschalten

(Richtige Reihenfolge beim einschalten beachten - erst Kmodem komplett hochfahren lassen - dann erst den Router ein/zu schalten) - testen.

 

Oder mal direkt mit der Leitung vom Rechner ans KModem gehen (ohne Router da zwischen) - testen.

 

Tritt das bei allen eventeuell vorhandenen PB Games bei Dir auf oder nur bei BF3 ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.