Jump to content

Archived

This topic is now archived and is closed to further replies.

Street

Linux BF42 Server will einfach nicht

Recommended Posts

Hallo,

ich habe nen BF42 Server auf meiner Linux Kiste installiert.

Nach dem Tut von Fisch.666. Ich bekomme es irgendwie nicht hin zu Konnekten.

Ich habe alles bis Installation des BVSM ohne Probleme geschafft. Jetzt muss ich noch Punkt 4. Verbindung zum Servermanager mit dem BVRM machen, aber ich raff einfach nicht wie.

Ist das BVRM ein Proggy? Wo kann ich das ziehen? Oder muss ich das in der Konsole eingeben?

Ich hab voll keine Ahnung. Merkt man glaub ich... :D

Hoffe auf Hilfe

Mfg Street

Edit:

Habe auch Alle Ports Freigeschaltet

Linux Rechner mit Suse Linux 10

Windows XP Rechner

hängt beides an einer Fritz Box

Share this post


Link to post
Share on other sites

Du kannst dir die beiden Dateien von hier ziehen http://www.blackbagops.com/bf1942/index.shtml

Einfach installieren wie beschieben und los gehts. Einmal den BFSM (Battlefield Server Manager) und dann die BFRM (Battlefield Remote Manager) mit dem du dann auf die Dateien des BFSM zugreifen kannst.

Soweit habe ich das dann auch hinbekommen nur machts bei mir zicken beim start

Share this post


Link to post
Share on other sites

Ich komme mit dem Programm nicht drauf. Er sagt mir immer das er nich Konnekten kann. Fehler nummer 10060. Was mache ich denn Falsch?

Share this post


Link to post
Share on other sites

Mit dem Programm BFRemoteManager. Der zeigt mir den Fehler an.

Aber mit dem HLSW zeigt er mir den Server an.

Mit dem Spiel komme ich auch nicht auf meinen Server.

Share this post


Link to post
Share on other sites

Hast du den BFSM denn auch drauf??

Das ist die "antwortstelle" und solltest das dingens auch starten mit:

---> Entpacken der beiden .con Dateien nach /pfad/zum/bf1942ordner/mods/bf1942/settings:

CODE

tar -xzvf BFServerManager20final.tgz useraccess.con servermanager.con

cp useraccess.con servermanager.con /pfad/zum/bf1942ordner/mods/bf1942/settings

3. Starten des BFSM mit:

(vorher muss die start.sh des BF1942 Servers 1x ausgeführt und wieder beendet werden damit der bf1942_linded symlink erstellt wird.)

Habe gerade deinen edit gesehen. Kann sein, das du deine interne IP angeben musst.

Das findest du, wenn du fritz.box eingibst und dann nach den netzwerkgeräten schaust und dann die Server Ip von dem Router eingibst

Share this post


Link to post
Share on other sites

Die Ip vom Router hab ich angegeben, beim BFMS. Den BFMS hatte ich schon Installiert.

Beim Server steht IP 0.0.0.0 drin. Wie kann ich das ändern?

Wie muss ich den BFMS nochmal Starten? Ich hab das Kommando vergessen und finde es gerade nicht.

Share this post


Link to post
Share on other sites

Steht doch alles beim fisch666 drinne

/index.php?showtopic=11872">http://www.bf-games.net/forum/index.php?showtopic=11872

3. Starten des BFSM mit:

(vorher muss die start.sh des BF1942 Servers 1x ausgeführt und wieder beendet werden damit der bf1942_linded symlink erstellt wird.)

CODE

bfsmd -daemon -path /pfad/zum/bf1942ordner




(falls in /usr/bin bzw. /usr/local/bin)



[code]

cd /pfad/zur/bfsmd

./bfsmd -daemon -path /pfad/zum/bf1942ordner

	





(falls in einem anderen Ordner)



Wenn Ihr beim starten des bfsmd diese Fehlermelung angezeigt bekommt:





QUOTE 	/bfsmd: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by ./bfsmd)	
dann läuft Eure Linux Distri noch nicht mit der glibc2.3 welche vom bfsmd benötigt wird. Falls dies der Fall ist müsst Ihr den BFSM per:

CODE

./bfsmd.static

starten. Vorher muss diese aber mit:

CODE

tar -xzvf BFServerManager20final.tgz bfsmd.static

cp bfsmd.static /usr/bin

chmod 755 /usr/bin/bfsmd.static

entpackt und in das gewünschte Verzeichniss kopiert werden.

Share this post


Link to post
Share on other sites

Jo, THX! Habs nicht gefunden :blink:

Habe den versucht zu Starten. Passiert nichts. Wenn ich das Kommando in die Konsole eingebe und Enter Tippe kommt nichts.

Habe mal beim BFMS die Log geöffnet.

22.05.2006 23:18:01 : Couldn't connect to Server Manager! Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht ordnungsgemäß reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat. (10060)

Das zeigt er mir.

Share this post


Link to post
Share on other sites

httest du es mal mit beiden ip's versucht??

wie hast du versucht zu starten??

In welchem ordner hast du versucht zu starten

Share this post


Link to post
Share on other sites

Nein. Geht nicht.

Habe gerade meine Interne IP 192.168.178.31 und meine Externe 195.158.168.96 eingegeben. Jedesmal der gleich fehler.

Ich habe sogar versucht auf 0.0.0.0 zu Konnekten. Aber das gleiche.

Das ist in /usr/bin drinne, habe bfsmd -daemon -path /usr/local/games/bf1942 eingegeben.

Share this post


Link to post
Share on other sites

Versuch mal dan bfsmd mal so zum laufen zu bringen und dann versuch das dingens erst mal einzustellen

ich werde morgen mich nochmal darum kümmern ausser fisch666 (der grad am mitlesen is) kann dir auf die schnelle helfen

Share this post


Link to post
Share on other sites

habe jetzt den BFSMD neugemacht. Aber wenn ich das Kommando mit der Path angabe eingebe kommt nur der Prompt.

Werde für heute auch Schluss machen.

Erstmal THX für die Hilfe bis Jetzt!!!

Share this post


Link to post
Share on other sites
Guest

Hi!

@street

Also ich würd an Deiner Stelle einfach nocheinmal von vorne Anfangen. Beende ersteinmal alle Instanzen des bfsm:

killall bfsmd

Share this post


Link to post
Share on other sites

Häh??? Jetzt gehts auf einmal... KA warum...

Habe das doch schonmal Neu gemacht...

Hmm Egal es geht! Was muss ich denn jetzt da alles einstellen?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.