Jump to content

Archived

This topic is now archived and is closed to further replies.

ignus

Mein GameServer hoppelt

Recommended Posts

Hallo,

ich hab mir mal auf meinem root Linux dual Core Server einen BF1942 Gameserver aufgesetzt.

So, damit das Ding nun einigermaßen rund läuft, wegen dualcore, hab ich das wie hier in einem anderen Beitrag beschrieben, auf einen Prozessorkern beschränkt. Das funktioniert auch soweit wunderbar.

Jetzt hab ich aber dennoch folgendes Problem:

Das Spiel hoppelt ab und zu. Will damit sagen dass es sowas wie ein invertierter Lag ist...

Das Spiel ist für knapp 2-3sec einfach mal doppelt so schnell - es ruckelt einfach mal in doppelter Geschwindigkeit (alle Bewegungen oder Berechnungen etc. laufen für die 2-3sec schneller ab).

Woran kann sowas liegen?

Hat jemand Erfahrung mit einem solchen Phänomen?

Ausserdem tät mich mal noch interessieren wie ich als Admin Teams swappen kann.

Ich hab dazu bisher keinen Befehl gefunden.

Ich finde es wäre eine dringend notwendige Sache da man auf den unterschiedlichen Maps die Seiten(allis o. rotarmist etc.) auch meist unterschiedliche Funktionen haben (Angriff oder Verteidigung) was zu völlig anderen Spieletaktiken der jeweiligen Seite führt.

Ich hoffe jemand weis dazu auch ein Rat ;)

mfg Ignus

Share this post


Link to post
Share on other sites

Ach ja siehst:

Falls ihr Euch auch mal selber vom hoppeln überzeugen wollt, hier ist die ip:

Server-IP: -- 78.46.107.69:14567 --

Der Server wird nicht gelistet - hab die 2-4 zusätzlichen Ports dafür nicht freigeschaltet, war mir zu doof.

Wie gesagt, es tritt nur ab und zu auf und folgt keiner Regel alla mapspezifisch und co.

Share this post


Link to post
Share on other sites

Hey,

das Problem besteht bei uns auch seit einigen Wochen.

Hast du zufällig irgendwelche Rankings online?

Bei uns passiert es verstärkt, wenn wir über Java das Ranking synchronisieren.

Aber auch sonst manchmal. (Alle 30 - 40 Minuten für 2 Sekunden) Vorher war es mal alle 2 Minuten.

Eine Lösung oder eine Erklärung kann ich leider auch nicht liefern.

Das Problem ist relativ neu und trat bisher nicht auf.

Meld dich, wenn du was weißt.

Share this post


Link to post
Share on other sites

selbiges problem haben wir auch, wenn wir bei unserer maschine die power-"geschichte" nicht manipulieren:

sprich man sollte der cpu volldampf geben, sonst wechselt die die cpu-frequenz immer.

bei susesystem sollte das "powersave" sein. da mal nachlesen.

Share this post


Link to post
Share on other sites

Danke simpson ich werd mal die powergeschichte probieren und dann nochmal bescheid geben :)

Share this post


Link to post
Share on other sites

Ich habe gestern unsere Powersave auch eingestellt. Ich habe dann 3h gespielt und es gab keinen speedbug mehr.

Share this post


Link to post
Share on other sites

Das wäre dann man einen Eintrag im Wiki wert, wie man das macht.

Share this post


Link to post
Share on other sites

powersave -f

ist die wahl, das setzt die cpu auf " highest supported frequency".

nach einem reboot wieder setzen.

Share this post


Link to post
Share on other sites

Jup ich konnte auch feststellen das nix mehr hoppelt.

Allerdings habe ich das Taktfrequenz skaling etwas anders eingestellt:

Da ich den BF1942 Gameserver auf CPU Kern 0 gesetzt habe, brauchte ich auch nur diesen ändern.

alles als root ausführen



#cpu Frequenz auslesen:

cd /sys/devices/system/cpu/cpu0/cpufreq

cat cpuinfo_cur_freq



#anzeigen des aktuellen cpu scalings:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor



#cpu Frequenz Scaling aendern:

echo performance | tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Im Grunde also nur eine kleine Änderung in einer kleinen Datei,

ohne den Server neu starten zu müssen und ohne *apt-get powersaved*. ;)

#folgende Governor (Frequensscalings) gibt es standartmässig:

ondemand - aktuellen Bedürfnissen an die Rechenleistung - standart

conservative - Bedürfnissen an die Rechenleistung angepasst - Anpassung Schritt für Schritt

performance - höchste erlaubte Taktfrequenz

powersave - niedrigste erlaubte Taktfrequenz

userspace - Dies ist kein Kernel-eigener Governor, vielmehr wird ein Governor im Userspace verwendet, wie z.B."powernowd".

Das Setting gilt übrigends nur so lange, bis der Rechner neu gebootet wird.

Auch hier alles hübsch nachzulesen:

http://wiki.ubuntuusers.de/Prozessortaktun...hlight=powersav

Share this post


Link to post
Share on other sites

ähm der Server muss nciht neu gestartet werden.

einfach den befehl "powersave -f" ausführen . Das wars.

WENN man den Server neu startet, muss man den befehl wieder setzen.

Share this post


Link to post
Share on other sites

Achso ha, ganz vergessen, eine Frage ist immernoch offen:

Wie ist das jetzt mit den Teams, kann man die nun irgendwie swappen oder geht sowas nicht?

Share this post


Link to post
Share on other sites

Hallo,

swapping teams: einen Seitentausch des kompletten Teams.

Bei einigen Karten spielt man ja entweder auf der Angreifer oder der Verteidiger Seite.

So, und ich würde es gern so einstellen, dass wenn eine solche Karte vorbei ist die gleiche Karte nochmal läuft bloß eben mit getauschten Teams. Dass ich eben jetzt nicht mehr Angreifer bin sondern Verteidiger z.B.

Ich hoffe ihr habt eine Idee dazu. ;)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.