Jump to content
Rubiks

BF 2 Patch-Problem

Recommended Posts

Morgen Leute! Seit längerer Zeit melde ich mich mal wieder...

Und zwar hab ich folgendes Problem:

Gestern ist mein Rechner abgeschmiert und ich musste nochmal alles komplett neuinstallieren (soweit kein Problem), allerdings hab ich bei BF2 & BF SF das Problem das ich nicht mehr patchen kann. D.h. ich habe zwar von BF2 die Version 1.0 und von BF SF die Version 1.1 drauf, kann aber keine anderen Versionen installieren....

Muss ich mein BF einzeln patchen oder gibts einen Fullpatch der die kleineren Updates mit beinhaltet?? Bei der installation von der Full 1.4 bricht er immer mit einer Fehlermeldung die instalation ab, meldet aber anschließen das der patch richtig installiert wurde... Beim starten von BF kommt jedoch die Fehlermeldung "... shader.." also ist der Patch doch nicht richtig installiert worden.

Kann jemand helfen? Würd gern 1.5 zocken

Link to comment
Share on other sites

Guest Da_Baleno

Hi Rubiks

Also ich würde an deiner Stelle alles einzeln patchen.

BF2 installieren

-> Patchen

SF installieren

-> Patchen

Da die beiden Boosterpacks nun im Patch 1.5 integriert sind solltest AF und EF nicht einzeln laden müssen über den Download Manager.

Ich hatte alles auf Patch 1.41 aufm Rechner (inkl. Boosterpacks) und habe dann einfach 1.5 drüber geworfen, einmal neu gestartet und alles lief einwandfrei.

Also kannst es auch so versuchen:

Bf2 installieren

-> Patchen (1.41)

SF installieren

-> Patchen (1.41)

-> Patchen (1.5)

Hast du schon die Service Packs installiert? die könnten auch Probleme machen

Wenns nicht klappt einfach nochmals melden.

Gruss Baleno

Link to comment
Share on other sites

Ney du... wenn dann Bf2 installen dann Sf installen und danach erst 1.41+1.5...

Link to comment
Share on other sites

Reihenfolge ist wie Grapplin es gesagt hat ganz easy eig:

BF2

SF(und damit automatisch 1.2x oder so)

1.41

1.5

Dann hast du ein Bf2 auf dem neuesten Stand mit SF und beiden Boostern.

Link to comment
Share on other sites

Wenn der Patch 1.41 Probleme macht könnte es eventuell sein das einfach die Patch-Datei defekt ist. Am besten mal neu herunterladen (z.B. hier) und nochmal probieren.

Link to comment
Share on other sites

So, klappt irgendwie immer noch nicht >.<

Hier mal die Fehlermeldung, die ich bekomm wenn ich BF2 starten will (nach Patchversuch mit 1.41):

Error!

mods/bf2/shaders/lightning.fx not found! _DO_check your working directory, _AND_ sync your shaders folder before calling upon your local rendering programmer/GP. (really!)

Wenn ich bei mir in den Ordner mods/bf2/shaders schau, sind keine Datein hinterlegt. UNd wenn ich den ZIP-Ordner "shaders-client entpacke, seh ich auch keine lightning.fx-datei ...

Wie gesagt.. BF2 1.0 & BF2 SF 1.2 läuft problemlos... sobald ich aber patchen will zickt mein rechner rum >.<

EDIT: Neue Patchdatein hab ich mir mal runtergeladen (@Hawkeye), PRoblem bleibt bestehen.

Edited by Rubiks
Link to comment
Share on other sites

hi

hast du nur denn 1.41 installiert oder auch die anderen 1.2,1.3,1.4,1.41 und dann 1,5

versuch das mal mache ich immer wenn ich das neu installiere

XXDRambo

Link to comment
Share on other sites

das hab ich auch ganz oft mit special forces geabt das problem mit den shadern, eigentlich musst du nur die fehlenden shader einfügen, ich lad dir die lightning.fx hier einfach mal hoch, vllt gehts ja

Lightning.rar

Link to comment
Share on other sites

@ Hillepille:

Danke für die lighting.fx datei! Ich konnte mein 1.0 BF jetzt endlich ERFOLGREICH auf 1.2 patchen... allerdings wird jetzt beim start von bf 1.2 die rain.fx datei vermisst >:<

Könntest du mir deinen KOMPLETTEN shader ordner senden (entweder hier reinstellen oder mir ein rapidsharelink per pm senden)??

Wär echt dankbar!

Gr

rubiks

Link to comment
Share on other sites

Mal ne ähnliche frage, wie ist das wenn ich nur BF2 neuinstalliert habe?

brauch ich da auch den 1.41 patch ? ich dachte der 1.5er währ ein fullpatch

Link to comment
Share on other sites

Leider musst du den 1.41er vorher installieren. Mit den Boosterpacks und auch noch als Fullpatch wäre der 1.5er zum einen riesig geworden (zum anderen hat Dice irgendwas von 1.41 auf 1.5 geändert was es schwierig gemacht hätte einen Fullpatch zu kreieren und so den Relase noch mehr verschoben hätte. Bin mir da aber nicht ganz sicher)

Link to comment
Share on other sites

Komisch, komisch...

Hab jetzt einfach mal weitergepatcht (1.2 => 1.5), Rechner neugestartet und siehe da... BF2 startet ohne zu meckern!!!

Vermutlich "tauchten" dann die "fehlenden" Datein ja doch noch auf.

Dank nochmal an Hillepille, für die ligthing.fx ...

Jetzt kann ich endlich die neuen Mods zocken

:daumenhoch:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.