Jump to content

Archived

This topic is now archived and is closed to further replies.

illMoh

Spiel ruckelt nach ca. 10 Minuten

Recommended Posts

Hallo Allerseits,

nach dem ich mich nun seit 2 Tagen durch alle möglichen Battlefieldforen lese und immer noch keine aktzeptabele Lösung für mein Problem gefunden habe frag ich jetzt mal explizit nach.

Also ich habe BF 1942 samt aller Addons und des neusten Patchs (1.61b) korrekt, von Original CDs mit Orginial Keys und auf meinem D: Laufwerk in einem alternativen Ordner installiert. Mein Rechner ist zwar nicht mehr der Neuste genügt den Systemvorraussetzungen aber allemal. Außerdem sind alle Treiber auf dem neusten Stand und BF 1942 wird im Kompatibilitätsmodus Windows XP SP3 gestartet.

OS: Windows 7 64 Bit Professional

GPU: nVidia GeForce 7950GT

CPU: Intel Core2Duo 6400

RAM: 2GB DDR2

So nun passiert folgendes:

Das Spiel startet ganz normal, ich kann auf Server connecten und schön flüssig mit 60-100 FPS spielen. Das allerdings nur so 10 Minuten lang, danach fällt die FPS-Rate unter 30 und es ruckelt wie en Daumenkino.

Daraufhin habe ich angefangen mich durch Foren und Threads zu kämpfen und bin in einem auf die Ursache des Problems gestoßen: der Sound! Ich habe dann als das Ruckeln gerade wieder angefangen hat im Menü den Sound ausgeschaltet und als ich wieder ins Spiel kam war das Ruckeln wieder weg. Schaltete ich den Sound wieder an, war es wieder da! In dem Thread wurde als Lösung angegeben, dass man die Hardwarebeschleunigung aktivieren soll.

Soweit schön und gut, aber ich verfüge an meinem Rechner über 3 Soundkarten:

- Eine ASUS Xonar mit meinem 5.1 Soundsystem

- Eine Onboard Realtek HD Audio von meinem ABit AB9QuatGT Mainboard

- Eine Sennheiser PC 155 USB Minisoundkarte von meinem Headset

Die Lösung des Problems (im BF Menü die Hardwarebeschleunigung im Soundmenü zu aktivieren) funktioniert aber nur mit der ASUS Xonar und dann läufts auch die ganze Zeit über flüssig. Allerdings ist die Soundkarte auf Musik ausgelegt und Gamesounds verzerren ganz schön oder werden nicht richtig wiedergegeben, außerdem möchte ich nicht ständig mit meinem 5.1 Soundsystem zocken oder immer wieder umstecken müssen.

Bei den beiden anderen Soundkarten an denen ich mein Headset dauerhaft anschließen kann laufen alle Sounds sauber und ohne zu verzerren, allerdings ruckelt es nach einiger Zeit wie beschrieben. Die Hardwarebeschleunigung lässt sich hier nicht anschalten. Kann mir jemand bei diesem echt nervigen Problem helfen?

Danke im vorraus und Grüße

illMoh

Share this post


Link to post
Share on other sites

Doch hatte ich sogar die ganze Zeit, deinstalliert und deaktiviert. Habe die Treiber aber wieder aufgespielt, weil ich dachte vll. liegts nur an der USB Soundkarte, dass ich die Hardwarebeschleunigung nicht einschalten konnte. :/

Share this post


Link to post
Share on other sites

Ja habe alle XP Varianten durch, passiert immer das Gleiche! :/ Habe Win7 64 Bit (habs oben auch geändert).

Share this post


Link to post
Share on other sites

Windows 2000 oder Windows 98 schon probiert? Und gibt es spezielle 64-bit Treiber für deine Soundkarte? Wenn ja, ist das der aktuell installierte Treiber?

Share this post


Link to post
Share on other sites

Nee die beiden noch nicht, denke aber mal dass das damit nichts zu tun haben dürfte weil die Hardwarebeschleunigung im Menü ja mit der ASUS funktioniert. Für die USB Soundkarte gibts garkein Treiber bzw. Firmwareupdate (was ja eig. auch einer ihrer Vorteile ist - reinstecken und los gehts). Für die Realtek hab ich gerade noch eine Version neuer gefunden (2.67 statt 2.65) bin aber auch eher skeptisch, dass sich da was ändert, probiere es trotzdem gleich mal aus.

Danke in jedem Fall schonmal dass du dir die Mühe machst mir zu helfen.

Share this post


Link to post
Share on other sites

Nur um ganz sicher zu gehen, das es sich nicht um eine Überhitzung deiner ( nicht besonders fetten) Grafikkarte handelt.

benutzt du ein bf1942-Profil im NVidiatreiber, bei dem vielleicht alles aufgerissen ist? Wenn ja, versuche mal mit moderateren Einstellungen zu spielen.

Ansonsten ist ein Problem mit deinen Soundkarten auf jeden Fall das Offensichtlichste.Bei der Wahl des passenden realtek treibers brauchst du viel Losglück. Da habe ich bei Neuinstallationen ich immer viel Freude dran. Die Soundeinstellungen auf Niedrig hast du sicher schon probiert.....?

Share this post


Link to post
Share on other sites

Fragen wir mal anderes . Ist dieser Fehler nur wenn du online spielst? Oder auch wenn du offline bist.

Mir fallen aber zwei weitere Punkte auf:

1 . Für win7 hast du zu wenig Arbeitsspeicher drauf 3GB sollten es auf jedenfalls mal drin sein .

2. Deine Grafikkarte ist auch nicht die schnellste . Hier sollte auf jedenfalls was besseres rein.

Achte mal drauf ob wenn er anfängt zu ruckeln ob wenig Gegner drauf sind oder nicht?

Falls viele drauf sind liegt es wohl oder übel an der Grafikkarte . Teste mal indem du offline eine Karte startest alleine und siehst ob der Fehler noch auftritt.

Share this post


Link to post
Share on other sites

Ja das mit den Realtektreibern stimmt. Was den Arbeitsspeicher angeht, wollte ich sowieso mal aufbessern, aber daran liegt es nicht, genauso wenig wie an der Grafigkkarte und ihren Einstellungen (sieht man ja i.d.R. mim Auge oder an der Temperatur). Battlefield 2 zum Beispiel läuft auf Einstellungen "Hoch" super flüssig und ohne Probleme. Und wie gesagt, sobald ich den Sound über die ASUS Soundkarte einspiele gehts ja auch. Aber das möchte ich aus den o.g. Gründen nicht.

Mein jetziges Problem besteht darin, warum kann ich mit keiner anderen Soundkarte die Hardwarebeschleunigung einschalten? Und kann man das eventuell über Windows regeln oder vllt am Battlefield rumschrauben? Bzw. woran liegt es ob ein Gerät Hardwarebschleunigung kann oder nicht?

Share this post


Link to post
Share on other sites

So, habe nun den neusten Treiber für meine Soundkarte (Realtek 2.67 Win7 64bit) drauf und die anderen beiden kompatibilitätsmodi ausprobiert. Alles beim Alten. :-/

Allerdings habe ich herausgefunden, dass je höher die Kanalzahl in den Soundeinstellungen ist, desto schneller das Ruckeln anfängt.

Share this post


Link to post
Share on other sites

Hast du evtl. schon mal geschaut, ob die Hardwarebeschleunigung der beiden Soundkarten in Windows aktiviert ist?

Share this post


Link to post
Share on other sites

Weiß nicht wo ich sie dort aktivieren könnte. In DxDiag steht mal nix und in den Treibern der Realtek auch nich. :/

Share this post


Link to post
Share on other sites

Schau mal in der Systemsteuerung unter Audio bzw. im Gerätemanager in den Einstellungen der jeweiligen Karte.

Share this post


Link to post
Share on other sites

Hab ich schon. Sowohl in den Lautsprechereigenschaften als auch in den Hardwareeigenschaften hab ich keine Möglichkeit irgendetwas zu verstellen und von Hardwarebschleunigung is da leider auch nix. Bin echt am verzweifeln...

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.