Jump to content
Sign in to follow this  
Poow

Modding für Bf42: Kleine Fragen

Recommended Posts

Ich glaube den Thread hatten wir noch nicht.

Irgendwie ist hier sonst alles mit BF2 vermischt.

Also Ich habe eine neue Mod erstellt und wollte nach diesem Tutorial ganz einfach eine Textur ändern. (Gute Seite übrigens. Ist ein Backup der Original Seite mit vollständigen Links)

Das ganze nur zum Test ob meine Mod funktioniert. Also PS auf gemacht, dds geändert und in das Texture Verzeichnis meiner Mod gepackt:

C:\Programme\EA GAMES\Battlefield 1942\Mods\Testfield\Texture

Spiel gestartet (El Al) und da ist alles wie gehabt. Nichts hat sich geändert. habe allem möglichen Texturen versucht, die nicht spezifisch für "Africa" sind. Aber auch die für "Africa" Maps.

Eigentlich sollte alles klappen. Tut es aber nicht.

Ideen?

Share this post


Link to post
Share on other sites

Ist die Mod gepackt oder entpackt?

Hast du sie aktiviert/gestartet? (Man weiss ja nie. ^^)

Welches Format hat die Textur? (dds in DXT3?)

Welche Auflösung?

Share this post


Link to post
Share on other sites

An das Client-seitige Modding mit eigener Mod mache ich mich das erste mal ran.

Ich habe in meinem Mods Ordner:

Testfield

-> Archives ->1942 ->Levels (leer)

-> Movies -> Background.bik (1kb, leerer Platzhalter denke ich mal)

-> Texture -> "Zero01_o.dds" & geänderte "Colt_o.dds"

Die Mod ist also nicht gepackt. Habe keine RFA Files im Ordner sondern einfach die Texturen in "Texture" gespeichert. (So wie ich es im Tutorial verstanden habe.

Die Textur ist in eine *.dds Datei in DXT3 und hat 72 Pixel/Zoll

Und die Mod habe ich auch aktiviert. Stimmt schon, oft übersieht man sowas :rolleyes:

Share this post


Link to post
Share on other sites

Wenn Levels leer ist kann ja nix passieren. ;)

Mach nen Patch für El Al und ändere in der .../Menu/Init.con die ID (game.setMapId "Testfield").

Und ich bin mir nicht ganz sicher, aber der Texture Ordner sollte glaube ich im Archives Ordner sein.

Share this post


Link to post
Share on other sites

Die Ordner wurden so vom MDT erstellt. :confused:

Ich dachte es wird einfach nur die Textur geladen.

Es steht dort ja game.addModPath Mods/Bf1942/

Wird die Mod 1942 dann einfach geladen, ohne dass meine Textur überschrieben wird?

Was soll im Patch stehen? Ich mache dort ja erstmal keine Änderungen.

Einfach eine leere rfa als El-Al Patch speichern, die nichts ändert? :fear2:

Verstehe die Logik noch nicht ganz, die beim Erstellen einer eigenen Mod greift.

Edited by Poow

Share this post


Link to post
Share on other sites

Es gibt hier ein Backup, bei dem alle Links funktionieren.

Das liegt darüber hinaus auch schon bei mir auf der Platte ;)

€ Steht auch schon im Firstpost.

Edited by Poow

Share this post


Link to post
Share on other sites

Momentan wird deine Mod zwar erst gestartet aber die Dateien werden nicht benutzt, da du ja eine normale BF42 Map (mit entsprechender MapID!!) startest!

Also erstmal die origniale El_Alamein entpacken und alles löschen ausser .../bf1942/levels/El_Alamein/Menu/Init.con und dort die Zeile game.setMapId "bf1942" ändern in game.setMapId "Testfield".

Dann die Map packen als El_Alamein_999.rfa und in den Levels Ordner deiner Mod packen.

Die Init.con im Testfield Ordner muss diese Zeilen enthalten:

game.setCustomGameName Testfield <--legt den Namen (ModID) der Mod fest

game.addModPath Mods/Testfield/ <--legt fest das die Dateien dieser Mod genutzt werden

game.addModPath Mods/BF1942/ <-- "dito" (Da Vanilla ja als Basis genutzt wird müssen diese Dateien auch geladen werden)

Share this post


Link to post
Share on other sites
Es gibt hier ein Backup, bei dem alle Links funktionieren.

Das liegt darüber hinaus auch schon bei mir auf der Platte ;)

€ Steht auch schon im Firstpost.

Ok, soweit habe ich nicht zurückgeschaut. Ich bin aber auch gerade am ziehen mit HTTrack Website Copier.

Share this post


Link to post
Share on other sites

Habe ich auch benutzt, Sind gerade mal ~ 40Mb

Gepackt 22 MB.

Hat trotzdem schön lange gedauert, lag bestimmt an den Einstellungen.

Ich könnte es dir schicken, wenn es bei dir auch so lange dauert.

Share this post


Link to post
Share on other sites

Leider klappt es nach wie vor nicht :(

Die Zeile war auch nur in der Init.con der El Al Version des letzten offiziellen Patches zu finden. Aber daran wird es nicht gelegen haben.

Die Texturen in den Ordner "Archives" zu schieben hat auch nichts genutzt. :unsure:

Share this post


Link to post
Share on other sites

Dann pack die Texturen zu einer Texture.rfa und pack sie ins Archives-Verzeichnis.

Und kopier mal die Objects.rfa (Vanilla) auch in das Verzeichnis.

Share this post


Link to post
Share on other sites

Super, funktioniert :daumenhoch:

Verzeih mir die Wahl des Testobjektes :whistling:

post-24944-1254497904_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.