Jump to content
Dayjay

Der Linux Thread

Recommended Posts

€ @DayJay Wenn ich fragen darf, wo findet denn nun meine Signatur Verwendung? Ich bin neugierig :D

Ich kam noch nicht dazu was zu machen. :(

Share this post


Link to post
Share on other sites

Mein Filezilla crasht seit letzter Zeit immer wenn ich einen neuen Tab öffnen will.

Als Fehlermeldung erhalte ich immer

filezilla: relocation error: filezilla: symbol _ZN13wxAuiNotebook15SetSelectedFontERK6wxFont, version WXU_2.8 not defined in file libwx_gtk2u_aui-2.8.so.0 with link time reference

Liegt wohl nicht an filezilla selbst sondern an den "wxwidgets". Gibts nen Fix dafür? Oder kennt jemand einen anderen guten FTP Clienten der Tabs hat?

Share this post


Link to post
Share on other sites
This is a problem with the Ubuntu package in question, it needs to be re-built using the new wxWidgets version.

:confused:

Share this post


Link to post
Share on other sites
Oder kennt jemand einen anderen guten FTP Clienten der Tabs hat?

Konqueror. Oder zumindest damals zu 3er Zeiten.

Aber probier doch mal FileZilla aus der Soße zu bauen, das geht doch mit apt. Nur frag mich bitte nicht wie^^

Share this post


Link to post
Share on other sites
Konqueror. Oder zumindest damals zu 3er Zeiten.

Gnome Benutzer hier. :puuuh:

Aber probier doch mal FileZilla aus der Soße zu bauen, das geht doch mit apt. Nur frag mich bitte nicht wie^^

Ja, setz ich mich morgen dran, hab jetzt gleich Feierabend. :D

Share this post


Link to post
Share on other sites

Kann mir einer von euch sagen wie ich einen FTP User anlegen kann der ausschliesslich nur in ein Verzeichnis kommt und dort sachen hoch/runter laden kann?

Mein Betriebssystem: Debian Lenny

Share this post


Link to post
Share on other sites

FTP benutzt doch nur die Nutzer des Systems. Also legst du einen stinknormalen Nutzer an, der in keiner besonderen Gruppe ist (video, audio, usb, was auch immer) und weißt ihm mit usermod -m /der/ordner den entsprechenden Ordner als Home-Verzeichnis zu. (Evt auch mit usermod -s /dev/null die Shell verweigern.)

Nun muss dein FTP-Server natürlich noch das Userjail unterstützen, sodass er die Benutzer in ihren Home-Verzeichnissen einsperrt. proFTPd macht das in der Standardeinstellung bereits. Die Option lautet "DefaultRoot ~", kommt in die proftpd.conf und betrifft alle Benutzer. Das geht AFAIK aber auch nutzerweise.

Also alles recht simpel.

Wenn du nun noch weitere Verzeichnisse für den Nutzer freigeben willst, so musst du sie mit bind hineinmounten. Symlinks sind bei proFTPd aus Sicherheitsgründen standardmäßig deaktiviert, können aber auch mit dem vroot-Modul wieder aktiviert werden.

Edited by der nachbar

Share this post


Link to post
Share on other sites

Prima. Hab Montag Filezilla selber kompiliert und was wird heute nach Monaten aktualisiert? Richtig... -.-'

Share this post


Link to post
Share on other sites

Eigentlich schon aber gab es gab vor gut 2 Monaten ein Update für die "wxwidgets" deshalb ist filezilla immer beim öffnen einen neues Tabs gecrasht. Musste die ganze Zeit zum Glück nix mit FTP machen bis letzten Freitag. Und 5 Tabs sind halt angenehmer wie 5 Fenster.

Naja, am Montag kompiliert und gestern wurde nach 2 Monaten das Ding tatsächlich auch im Repository aktualisiert.

Share this post


Link to post
Share on other sites

Mag mir jemand bitte zur Hand gehen?

Folgende Situation:

S-ATA-Platte: MBR/MFT/Part.-Table, irgendwas davon is unter Windows im Sack aber per Linux einwandfrei erreichbar.

Host: W7 x64

Guest: VMware Player incl. Ubuntu (VMware Tools installiert, Shared Folder eingerichtet (in VM & und unter Win freigegeben))

Ziel:

Daten von externe S-ATA Platte #1 auf interne S-ATA Platte #2 kopieren.

Problem: Shared Folder unter Ubuntu sichtbar machen/mounten

- /mnt/hgfs is bekannt aber der Sack will nich

- ich bin ein absoluter Linux-Noob

- ich komm mit den Befehlen grundsätzlich klar

- terminal is natürlich "gesudot"

- ich hab keine Erklärung gefunden (und dutzende getestet), mit der ich den Ordner unter ubündü sichtbar machen kann.

- ich such weiter aber mir geht langsam die Zeit dafür aus; Datenrettung ist top Priorität

e: Ergänzung

Edited by KwanzaBot

Share this post


Link to post
Share on other sites
- /mnt/hgfs is bekannt aber der Sack will nich
Inwiefern bekannt? Existiert der Ordner lediglich oder ist er auch in der /etc/fstab eingetragen?

Ich hab von den VM Ware Sachen nun kaum Ahnung, aber zu diesem Mountpoint muss irgendwo ja noch ein Gerät in /dev/ gehören. Wenn es in der /etc/fstab eingetragen ist, müsste es ja mit:

sudo mount /mnt/hgfs

einzubinden sein.

Bzw

sudo mount /dev/dasgerät /mnt/hgfs

wenn das Gerät zwar existiert, aber nicht in der fstab steht.

sda wäre die komplette erste Sata-Platte, aber sda1 die erste primäre Partition, also aufpassen beim Einbinden.

Alternativ falls das alles nicht funktionieren will und es eilt, einfach den proFTPd installieren, starten (sollte Ubuntu automatisch machen), dann die zu rettende Partition ins Heimverzeichnis reinmounten (proFTPd hat in der Standardeinstellung ein Userjail, siehe meinen obigen Beitrag, falls du es einfach deaktivieren willst, um überall über den FTP Zugang hinzukommen)

mkdir /home/nutzer/platte

sudo mount /dev/dieplatte /home/nutzer/platte

Zur Not, falls sie schon automatisch eingebunden ist, macht sich ein bind auch ganz gut:

mkdir /home/nutzer/platte

sudo mount -o bind /media/datenplatte /home/nutzer/platte

und die Platte ist an beiden Orten zu sehen.

Dann per Filezilla den Kram in der Windose runterholen.

Samba Geschichten empfehlen sich eher nicht dafür, FTP ist schneller.

Edited by der nachbar

Share this post


Link to post
Share on other sites

Ok. Das sind schon mal Tipps. Danke soweit. Im Prinzip ist die Lösung eventuell ganz einfach.

Denn im fstab steht die Platte und der Share nicht drin.

Wenn du mir ne Quelle nennen kannst, wie ich mir die entsprechende Einstellung erschließe, müsste der Fisch eigentlich vom Teller sein.

Quellen, die ich momentan in der Mangel hab:

http://www.tuxfiles.org/linuxhelp/fstab.html

http://wiki.archlinux.org/index.php/Instal...Linux_in_VMware

Der Punkt für mich is: Ich kann in die fstab eintragen. Nur wie finde ich heraus was genau ich dort eintragen muss.

Das einfache kopieren von Einträgen anderer Leute waren erwartungsgemäß nicht erfolgreich. Aber ich kann mir nich erschließen, auf welche Werte ich achten muss bzw. woher ich die richtigen bekomme.

:kritisch:

Der Hintergrund mit dem VM Player ist ja, dass dort keine Partitionen des Host-Systems auftauchen.

Erst wenn ich im Host Ordner freigebe, kann ich die im Guest als Netzlaufwerk mounten. So zumindest unter Win-Guest.

So. Und genau diesen Vorgang möchte ich eben im Linux-Guest durchführen.

Und ich muss diesen "share" erst einbinden, da die Platte auf der der Linux-Guest gammelt, eine virtuelle ist mit der Größe von 20GB. Der Umfang der zu sichernden Daten liegt bei ~600GB.

Das mounten der zu sichernden Platte ist kein Problem. Die schmollt gerade im Wechselrahmen. Aber eben die interne, leere Platte muss jetzt noch i-wie her und ich kann per Drag&Drop den Sack zu machen; oder könnte.

:trollface:

Zeit: ja, naja. Ich möcht einfach langsam damit fertig werden und meine Zeit wieder in andere Sachen investieren.

Für weitere Tipps zu dem fstab-Dingen wär ich extrem dankbar.

^_^

Share this post


Link to post
Share on other sites

In die fstab kommt einfach nur rein, was du per normalen mount-Befehl händisch eingeben würdest, um die Platte einzubinden, sodass das System sie beim Starten schon von selbst einbindet oder zumindest dem Mountpunkt ein einzubindendes Dateisystem zuweisen kann.

Das ganze gilt natürlich nur für statische Dinge. Dynamisch angeschlossene Datenträger werden durch einen anderen Dienst automatisch verwaltet (autofs, hal, udev... was auch immer da Ubuntu inzwischen hat).

Das ist aber alles schnurzpiepegal für dich, da du ja nur auf die Freigabe wie auch immer zugreifen willst, also reicht es, wenn du einmalig den richtigen Mountbefehl in die Konsole packst.

Ich schau mal schnell, wie das bei VM Ware aussieht....

Achja, proFTPd+FileZilla und Drag&Drop läuft rund ;-)

€ So...

tipp als normaler Nutzer mal "id" in die Konsole (also ohne sudo-Gedöns!) und merk dir deine uid (User ID) und gid (Group ID).

Dann editier die fstab

sudo nano /etc/fstab

und schreib rein

.host:/ /mnt/hgfs vmhgfs defaults,ttl=5,uid=DEINEUID,gid=DEINEGID,user 0 0

speichern und zuguterletzt:

mount /mnt/hgfs

Ob mit oder ohne sudo ist dank dem "user" Parameter nun egal.

Wenn es nicht funktionieren sollte, würd ich gerne Fehlermeldungen sehen. Sprich jene von mount selber, was bei

sudo tail -n 25 /var/log/messages

und

dmesg

rauskommt.

Hoffe das hilft schon mal.

Edited by der nachbar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.